Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2005
    Posts
    313

    Unanswered: How to reduce the size of the MS Access

    Hi:

    I have one problem.

    If I create many many tables, then delete them, then create new tables, so on. The size of the MS Access file will become large.

    So, how can I reduce the size of the file? Even though I delete the tables, the size will NOT become less, so how to reduce the size of the file?

    Please let me know, thanks a lot. Thanks.

  2. #2
    Join Date
    Mar 2005
    Location
    Phoenix AZ
    Posts
    56
    Do a compact and repair on your database. Go to Tools menu > Database Utilities > Compact and Repair.

    This should reduce the size of your database considerably.

    Hope this helps!

    Ben

  3. #3
    Join Date
    Feb 2004
    Location
    New Zealand
    Posts
    1,424
    Provided Answers: 8
    Set the Data to compact on close

    Tool -> option -> general compact on close


    If this is the backend database sitting on the server

    Write a Macro call autoexec and get to to quick the program.
    then on the server about mid nite
    get the schuler to open the database
    autoexec run which close the database which start the compacting

    nice simple way of compacting the database
    hope this help

    See clear as mud


    StePhan McKillen
    the aim is store once, not store multiple times
    Remember... Optimize 'til you die!
    Progaming environment:
    Access based on my own environment: DAO3.6/A97/A2000/A2003/A2007/A2010
    VB based on my own environment: vb6 sp5
    ASP based on my own environment: 5.6
    VB-NET based on my own environment started 2007
    SQL-2005 based on my own environment started 2008
    MYLE
    YOUR PASSWORD IS JUST LIKE YOUR TOOTHBRUSH DON'T SHARE IT.

  4. #4
    Join Date
    Jan 2005
    Location
    Nanded, India
    Posts
    397
    it seems your db is not on server and you might have kept all the tables in one db.

    Create 2-3 other dbs files and export your large tables into it. Then re-connect to your FE (Front End) db. Make sure that you set 'Compact on Close' check mark on bothe all Back End and Front End dbs

    This can be done from Tools - Option - General -Compact on Close

    Another idea is to make MDE of your front end (always compile your code) not to expanding the size whenever you open.

    Hope this help.

    With kind regards,
    Ashfaque

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •