Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2005
    Posts
    3

    Question Unanswered: java.sql.SQLException: Could not position within a file via an index

    Hi guys,
    First I had the 243 problem (Couldn't not position within a table(table name)) first. then I changed my isolation level to "READ_UNCOMMITTED", but now I got stuck on the error 245. when i looked at the lock logs, the other process was getting IX,X table/page/row locks on the table my process was trying to access, plus the X locks on the primary key and foreign keys.
    Any suggestion?
    Thanks very much!
    Zz

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Please run before SET LOCK MODE TO [WAIT|| n seconds], next run sql.

    Gustavo.

  3. #3
    Join Date
    Oct 2005
    Posts
    3

    index locking?

    Thanks Gustavo.
    Actually I did set the lock mode to -1(which is wait until the lock releases). Everything worked on my test(i did a lock table in exclusive mode) and my own application/proc waited until I issued the unlock command. However, as soon as the other app runs(the test team and I had the test case of running two apps at the same time), I watched the locks and the locks showed indexes being locked as well(along with some system locks that I am not familar with), then my app will get this 245 error Could not position within a file via index). of course, after 3 mins when the other app is done, my app worked as usual.
    Any insight is highly appreciated! I have been stuck with this issue for a week.
    Zhongyu
    Last edited by zhongyu; 10-05-05 at 13:06.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •