Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2005
    Posts
    2

    Thumbs up Unanswered: Problem with COMMENT statement

    Hi,
    I am using Sybase ASE version 11 on the Windows platform. When I try to use the COMMENT statement on a table, I get the following syntax error

    CREATE TABLE manas (col1 INT);
    COMMENT ON TABLE manas IS "Test comment"

    1> COMMENT ON TABLE manas IS "Test comment"
    2> go
    Msg 156, Level 15, State 1:
    Line 1:
    Incorrect syntax near the keyword 'ON'.

    Does anyone have any idea what could be the problem here?

    Thanks in advance.
    Regards,
    -Manas

  2. #2
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    there is no support for this syntax on any versions of Sybase. Perhaps if you describe what you are trying to do, there are always other means to achieve the same effect.

  3. #3
    Join Date
    Oct 2005
    Posts
    2
    Hi,
    Thank-you for your reply. I am referring to the documentation on the following link
    http://infocenter.sybase.com/help/in...15.0/title.htm

    If I do a search on COMMENTS, I get the syntax I am looking for. However when I try to execute the syntax, I get an error.

    Thanks again for your help

    Regards,
    -Manas

    Quote Originally Posted by willy_and_the_ci
    there is no support for this syntax on any versions of Sybase. Perhaps if you describe what you are trying to do, there are always other means to achieve the same effect.

  4. #4
    Join Date
    Mar 2001
    Location
    Lexington, KY
    Posts
    606
    That documentation is for ASE 15. You said you are on ASE 11. So, you cannot use the new features unless you upgrade.
    Thanks,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •