Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2005

    Question Unanswered: Pervasive Workgroup Engine will not start on Win2003 Server

    Our application is running on a Win2003 Server and invokes the Pervasive Workgroup Engine V8. When I remote into the Server via remote desktop(mstsc) as a RDP-TCP session, our application will start-up but the workgroup engine will not. I can manually start the work group engine by double-clicking w3dbsmgr.exe. In the PVSC.log, the error 8505 appears. However if I remote into the server as the console ie. mstsc /console, our application starts and the workgroup engine does also. It seems that the session id has to be 0 in order for the workgroup engine to auto start with our application. Can someone tell me why this is happening?

    Thanks for your feedback,

  2. #2
    Join Date
    Dec 2001
    Provided Answers: 4
    Can't say exactly why it's happening but I believe it has to do with how the WGE runs. It's probably the same reason the utilities don't work without a registry entry being changed (as seen at
    To modify the security registry setting on a Terminal Server client:

    We suggest that you create a backup of your registry before editing the registry. Refer to the online help for your operating system. Look for index entries such as "registry, backing up," or "emergency repair disk."

    1. Click Start4Run, then type regedt32 in the Open input field.
    2. Click OK.

    The Registry Editor opens.
    3. Find the following registry key:

    HKEY_LOCAL_MACHINE\Software\Pervasive Software\Utilities Interface\Settings\Restricted Access On WTS client
    4. Double-click REG_DWORD for the key.

    The Edit DWORD Value dialog opens.
    5. In the Value Data field, change the value from 1 to 0 (zero).
    6. Click OK.

    The REG_DWORD value should read 0x00000000 (0).
    7. Exit the Registry Editor.

    Changing this registry setting to zero grants Pervasive.SQL administrative authority to everyone who has access to the Terminal Server client machine. To restrict Pervasive.SQL administrative authority, you may want to restore the default value of the registry setting after DataExchange is installed. To do this, change the REG_DWORD value back to 1 (see step 5 in To modify the security registry setting on a Terminal Server client.

    You may also use regedt32 to change the permissions on the registry key so that only certain users are allowed to modify the key value.

    If you really need to run it in a REmote Desktop type session, then you should look into running it as a service (or switching to the Server Engine, which runs as a service).
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Oct 2005
    Thanks... this worked like a charm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts