Results 1 to 13 of 13
  1. #1
    Join Date
    Sep 2005
    Posts
    11

    Unanswered: Cannot connect Dynamic server

    Hi!

    Can anyone help me? I'm having some problems connecting into the Dynamic server. Below is my error message.
    "4GL run-time error number -25588.
    The apps cannot connect to Dynamic server sapbrioshm."

    I have setup in the etc/services for the tcp "cdosocsv 8890/tcp" and I also setup in sqlhosts for the onsoctcp.

    sapbrioshm onipcshm sgpux163 sapbrioshmsv
    sapbriosoc onsoctcp sgpux163 cdosocsv

    Anything should I still be setting up? So that I could connect to the database? Thanks!

  2. #2
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    Check the DBSERVER DBSERVERALIAS and NETTYPE settings in your $ONCONFIG file
    Last edited by artemka; 10-26-05 at 15:30.

  3. #3
    Join Date
    Sep 2005
    Posts
    11
    Hi artemka,

    The onconfig for the DBSERVERNAME "sapbrioshm" and DBSERVERALIASES "cdosocsv". For the NETTYPE, ipcshm,1,200,CPU and soctcp, 1,50,CPU.

  4. #4
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    sapbrioshm onipcshm sgpux163 sapbrioshmsv
    sapbriosoc onsoctcp sgpux163 cdosocsv


    The onconfig for the DBSERVERNAME "sapbrioshm" and DBSERVERALIASES "cdosocsv". For the NETTYPE, ipcshm,1,200,CPU and soctcp, 1,50,CPU.


    make the folloving changes in sqlhosts and try this "sapbrioshmsv" - sapbrioshm


    ipcshm,4,200,CPU and soctcp, 1,50,NET.

  5. #5
    Join Date
    Sep 2005
    Posts
    11
    Hi artemka,

    Should I be shutting down again the informix instance after I made the changes in sqlhosts and in the onconfig?

    After I made the changes in sqlhosts and onconfig and tried to run the program I still have the same error.

    4GL run-time error number -25588.
    The appl process cannot connect to Dynamic server sapbrioshm.

    Btw, thanks in helping me on my issues.

  6. #6
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Tested you define INFORMIXSERVER=sapbriosoc ?, next run 4gl program.
    Gustavo.

  7. #7
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    every time you make the change to $ONCONFIG you have to bounce the engine

  8. #8
    Join Date
    Sep 2005
    Posts
    11
    hi Gustavo,

    I change the INFORMIXSERVER = sapbriosoc. And run the 4gl program. Now, the error is

    Program stopped at "brioldma.4gl", line number 44.
    SQL statement error number -256.
    Transaction not available.

    Thanks for helping me.

  9. #9
    Join Date
    Sep 2005
    Posts
    11
    Hi artemka,

    I shutdown and reboot the informix instance and tried to run the program. I still received the same error.

  10. #10
    Join Date
    May 2004
    Location
    New York
    Posts
    248
    Program stopped at "brioldma.4gl", line number 44.
    SQL statement error number -256.
    Transaction not available.

    If this is what you are getting then simply your login is not turned on.
    Run ontape -B or -U tu turn the loggin on to the desired mode

    Cheers

  11. #11
    Join Date
    Sep 2005
    Posts
    11
    Hi artemka,

    Sorry for the delayed in response to you. Due to my computer crashed so I need to do all the reinstallation and recovery of my computer. I will just run the ontape -B or U? Please help since i'm not a DBA expert. Thanks.

  12. #12
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,
    I suggest that run ontape -s -L 0 -U databasename or ondblog unbuf databasename, next onbar -b -F; warning, the last form run fake back-up.

    Gustavo.

  13. #13
    Join Date
    Sep 2005
    Posts
    11
    Hi Gustavo,

    Now is working fine! When I run the program it can connect to the database. Thank you very much for you help. Same with artemka. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •