Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2005
    Sharjah, UAE

    Unanswered: SQL server problem...

    Hi! I'm creating a VB application using SQL Server. And in our SQL server, we have a linked Oracle Server. Now I'm trying to open records in that linked server (I'm opening a VIEW to be specific). And when I use SQL Server's Query Analyzer to open the table and see the records, I get this error:

    Server: Msg 7356, Level 16, State 1, Line 1
    OLE DB provider 'MSDAORA' supplied inconsistent metadata for a column. Metadata information was changed at execution time.
    OLE DB error trace [Non-interface error: Column 'ORDER_NO' (compile-time ordinal 1) of object '"LIPROD"."ALL_WORK_STEPS"' was reported to have a DBTYPE of 131 at compile time and 130 at run time].

    Now I thought that maybe it's just in the Query Analyzer that this pops up so I tried testing in my VB app. and I get the same run-time error. But when I tried creating a sample DB using Access and linked that table, I can open it up. I do understand what this error is trying to say but I don't know how to work around it 'coz I honestly am not well versed in SQL Server for that matter. Can someone please explain to me what's happening and is there any way for me to work around this problem?

  2. #2
    Join Date
    Mar 2003
    Reading, UK
    This error occurs due to change in the design after creating the connection check if the design is changed.

  3. #3
    Join Date
    Jul 2003
    The Dark Planet
    This is a problem related to a particular data type ... i dont remember which, this can be gotten around by encapsulating the table in oracle in a view and casting the concerned column as a varchar
    Get yourself a copy of the The Holy Book

    order has no physical Brett in The meaning of a Kaiser . -database data

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts