Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2005

    Unanswered: Urgent: Appending path for DLLs instread of using the real one

    Hi, I have a strange problem going on due to which my service is unable to create object of MS WinSock DLL. I even reinstalled the Windows without any luck to fix this issue.

    I'm using Windows 2003 Server Standard Edition (also tried with Web and Enterprise editions).

    The problem is, if I run my application in debug mode in VB6, everything just works fine, but the problem comes when this application runs as a service. I'm using FileMon and RegMon utilities by to monitor activity of this application. It gets path for mswsock.dll from registry and receives "%systemroot%\system32\mswsock.dll" in return, which is exactly what is stored in registry.
    But, my application appends this path into its own and with windows directory which makes it looks like

    C:\monitor\mservice.exe\%systemroot%\system32\msws ock.dll
    C:\WINDOWS\system32\%systemroot%\system32\mswsock. dll

    instead of just using the returned path to create object for MS Winsock which should be


    * this problem only occures on Windows 2003 platforms and not on Windows 2000.

    Another note is that my application does not create object for Winsock, but it uses CDOSYS.dll to send an email. cdosys.dll version is 6.5.6747.0

    I also tried changing owner of the service from Local System to Administrator, but that did not made any difference.

    Any help in this regard would be highly appreciated.

    Thanks in advance.
    Last edited by chuck59; 10-29-05 at 04:14.

  2. #2
    Join Date
    Oct 2005
    Has anybody found a clue for this? It's just a pane for me since my product's service is unable to send auto emails on Windows 2003

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts