Results 1 to 9 of 9
  1. #1
    Join Date
    Nov 2005
    Posts
    4

    Unhappy Unanswered: Sybase ASE on DEBIAN

    Hi,

    Has anyone experience with Sybase ASE on Debian Linux? I faced a problem I'm not able to resolve although I spent lot of times with it..

    some steps we done already:
    - package glibc (i think its version 2.2.4 which is listed at Red Hat's requirements) installed
    - user and its persmissions set
    - sybase-ase-11_0_3_3-6_i386.rpm installed using alien (to kernel 2.6.13)
    - pr and bk servers created according to the manual
    - database server started properly and have an isql prompt
    - installmaster script ran to create the stored procedures

    BUT. I can't connect from a Win XP client using ODBC driver downloaded from Sybase. Finally I founded out that somehow there is no any Open Client/Server support on my ASE server. (I can't see it when I run sybinit where it should be listed..)

    Also, I got errors when I'm trying to do some setup on Embedded SQL precomp since these files below are missing so sybinit can't initialize the same libaries:

    /sybase/lib/libintl.a
    /sybase/lib/libcomn.a
    /sybase/lib/libcs.a
    /sybase/lib/libsybtcl.a
    /sybase/lib/libct.a
    /sybase/lib/libct.a

    Do you have any idea what can I do with it? I need ODBC-based connection to the server.

    Thanks for any help.
    Mortin

    PS: We prefer a cost-free solution at the moment that's why free ASE is used with Debian instead of RH. But it's a hard way for me..

  2. #2
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    There are various issues here.

    First, the most likely problem is that your db server is listening on the localhost IP address. See http://www.peppler.org/FAQ/linux.html#q1.15 for some additional information.

    Second, the 11.0.x version of Sybase is *very* old. You can get a free 12.5.3 or 15.0 version that should be installable on debian with no particular problems.

    And lastly, you can use Fedora Core (which is free) as an alternative to Red Hat and get something that is very close to RH Enterprise...

    Michael

  3. #3
    Join Date
    Nov 2005
    Posts
    4
    Michael

    Many thanks You helped me a lot! The host file did not contain 'my host name'.

    Unfortunately I just realized another problem, namely, I also made a mistake when I didn't install the common sybase package before ase and doc packages. I think it was a big muff.. so according to your suggestion I'm going to install 15.0 version to Debian now.

    BR
    Mortin

  4. #4
    Join Date
    Dec 2005
    Posts
    2
    Do you know to set it up vice-versa?

    We have Sybase ASE Server running on windows 2000 and we have a system built from PowerBuilder. i managed to run it using wine but i can't connect to our Sybase Server (Windows). i've already installed open-client for it and i can make query through isql.

    here is the message when im running our system from console:

    The context allocation routine failed when it tried to load localization files!!One or more following problems may caused the failure

    Your sybase home directory is /opt/sybase-11.9.2. Check the environment variable SYBASE if it is not the one you want!
    Using locale name "en_PH.UTF-8" defined in environment variable LANG
    Locale name "en_PH.UTF-8" doesn't exist in your /opt/sybase-11.9.2\locales\locales.dat file

    here's the error from our system:

    "Unable to initialize Client Library Context"

    can someone help me?

  5. #5
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    You need to either change the value of the LANG environment variable, or edit the locale.dat file referenced in your error message to include the en_PH.UTF-8 in the [linux] section.

    Michael

  6. #6
    Join Date
    Dec 2005
    Posts
    2
    Already done that and it's solve and now the problem is how will i connect our system to sybase server? is there any revision that should be done to this:

    // Profile ourdb
    SQLCA.DBMS = "SYC Adaptive Server Enterprise"
    SQLCA.Database = "ourdb"
    SQLCA.ServerName = "OUR_SERVER"
    SQLCA.LogId = "user"
    SQLCA.AutoCommit = False
    SQLCA.DBParm = ""

    is there anyway i can use isql as my parm?

  7. #7
    Join Date
    Nov 2005
    Posts
    4
    Quote Originally Posted by mortin
    Michael

    Many thanks You helped me a lot! The host file did not contain 'my host name'.

    Unfortunately I just realized another problem, namely, I also made a mistake when I didn't install the common sybase package before ase and doc packages. I think it was a big muff.. so according to your suggestion I'm going to install 15.0 version to Debian now.

    BR
    Mortin
    ASE 15.0 is up and running and being tested now from Win client.
    But still having some minor issues: for example questions regarding the connection security (setup of SSL) because ASE will be set to work through internet.

    Many thx.
    Mortin

  8. #8
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    You mean that the client will connect directly to ASE from a remote site, without a VPN?

    If so you'll need the SSL add-on - this functionality is not part of the basic server (or of the free ASE Express edition).

    Alternatives include setting up an SSH tunnel, or some sort of VPN.

    Michael

  9. #9
    Join Date
    Nov 2005
    Posts
    4
    Quote Originally Posted by mpeppler
    You mean that the client will connect directly to ASE from a remote site, without a VPN?

    If so you'll need the SSL add-on - this functionality is not part of the basic server (or of the free ASE Express edition).

    Alternatives include setting up an SSH tunnel, or some sort of VPN.

    Michael

    Oh...so this problem is bigger then I thought at first. OK, I'm going to search if there's any free solution for SSH tunnel or VPN between Windows and Debian.

    Thanks!
    BR,
    Mortin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •