Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2002
    Location
    dayton, ohio
    Posts
    24

    Unanswered: Automated dump database ver 12.5

    I am trying to write a script to do an automated dump database, via cron, I have two files created one that executes the line below:
    SYBASE_HOME=$SYBASE;export SYBASE_HOME
    DB_NAME=kdb; export DB_NAME
    DB_SERVER=KHHPX001;export DB_SERVER
    SYBASE_USER=kdb; export SYBASE_USER
    DS_HOME=/home/kdb/dbowner; export DS_HOME
    DS_PATH=$DS_HOME/job\:$DS_HOME/bin\; export DS_PATH
    SYBASE=/appl/sybase; export SYBASE
    ISQL=/appl/sybase/OCS-12_5/bin/isql; export ISQL
    INSTALL=/appl/sybase/ASE-12_5/install;export INSTALL
    SYBASE_OCS=OCS-12_5;export SYBASE_OCS
    SYBASE_ASE=ASE-12_5;export SYBASE_ASE
    LM_LICENSE_FILE=/appl/sybase/SYSAM-1_0/licenses/license.dat:$LM_LICENSE_FILE; export LM_LICENSE_FILE
    SYBASE_SYSAM=SYSAM-1_0;export SYBASE_SYSAM


    /appl/sybase/OCS-12_5/bin/isql -Usa -P -i"/usr/local/bin/kdb.dump.script"



    and the other that has this information in it.

    dump database kdb
    to '/database/backup/kdb.dump'
    go


    I dont get anybackup, and i get an email message that says

    Status: R

    CT-LIBRARY error:
    ct_connect(): directory service layer: internal directory control layer error: Requested server name not found.


    *************************************************
    Cron: The previous message is the standard output
    and standard error of one of your crontab commands:

    any help would be greatly apprciated.
    thanks

  2. #2
    Join Date
    Sep 2005
    Location
    France, Paris
    Posts
    34
    Hello,

    According the error message you have: Requested server name not found
    /appl/sybase/OCS-12_5/bin/isql -Usa -P -Syourdataservername -i"/usr/local/bin/kdb.dump.script"

    or at least DSQUERY variable should be set:

    DSQUERY=yourdataservername ; export DSQUERY
    Regards.

  3. #3
    Join Date
    Jul 2002
    Location
    dayton, ohio
    Posts
    24

    Thumbs up

    That fixed it, Thanks so much for all your help..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •