Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2003
    Posts
    1,605

    Unanswered: How to set Windows Administrators group to db2 SYSADM_GROUP?

    Hi,
    how to set Windows Administrators group to db2 SYSADM_GROUP?

    I executed the following command:
    db2 update dbm cfg using sysadm_group Administrators

    And got error:
    SQL5132N The configuration parameter "sysadm_group" is null or too long. The
    maximum length is "8".

    My system:
    - winXP sp2
    - db2 workgroup edition v7.2fp5

    Thanks,
    Grofaty

  2. #2
    Join Date
    Nov 2005
    Location
    IL
    Posts
    557
    Create a new user group which is shorter
    Last edited by Cougar8000; 11-28-05 at 10:20.
    --
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows

    DB2 v9.7.0.6 os 6.1.0.0

  3. #3
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    I think on Windows the Administrators group has sysadm authority by default so you don't need so explicitly set it.

    If you have an issue with _local_ administrators not being recognised as such you'll need to "db2set DB2_GRP_LOOKUP=LOCAL" because by default DB2 goes to the domain for authentication.

  4. #4
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    Leave it to null and the default is the local admin group

    update dbm cfg using sysadm_group ''



    Cheers
    Sathyaram

  5. #5
    Join Date
    Jan 2003
    Posts
    1,605
    Hi,
    Thanks to you all. I have used sathyaram_s solution and it works fine.
    Thanks,
    Grofaty

  6. #6
    Join Date
    Nov 2005
    Location
    IL
    Posts
    557
    Grofaty,

    You might be happy to know that starting with V8.2 you are allowed to have upto 30 bytes in the name.
    --
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows

    DB2 v9.7.0.6 os 6.1.0.0

  7. #7
    Join Date
    Mar 2005
    Posts
    108
    Quote Originally Posted by sathyaram_s
    Leave it to null and the default is the local admin group

    update dbm cfg using sysadm_group ''

    Cheers
    Sathyaram
    Hi All,
    I am using DB2 V8.2 on Win XP profressional. I have the same ID on both local and domain, both in admin group. My original sysadm_group = admin. I could update dbm cfg (requres sysadm), but could not catalog a node! Inspired by Sathyaram's msg, I updated sysadm_group to null, then the behavior changed:

    Code:
     
    C:\Program Files\IBM\SQLLIB\BIN>db2 "catalog tcpip node xxxxxx remote yyyyyy server 50000 ostype linux"
    SQL1092N  "XXXXX   " does not have the authority to perform the requested
    command.
    C:\Program Files\IBM\SQLLIB\BIN>db2 update dbm cfg using SYSADM_GROUP ''
    DB20000I  The UPDATE DATABASE MANAGER CONFIGURATION command completed
    successfully.
    C:\Program Files\IBM\SQLLIB\BIN>db2 "catalog tcpip node xxxxxx remote yyyyyy server 50000 ostype linux"
    DB20000I  The CATALOG TCPIP NODE command completed successfully.
    DB21056W  Directory changes may not be effective until the directory cache is
    refreshed.
    Why could I update dbm cfg but could not catalog a node? How can you explain that?

    Thanks,
    Gary
    Last edited by DBA-Jr; 06-02-06 at 17:10.

  8. #8
    Join Date
    Oct 2007
    Posts
    246
    This is old post but faced similar issue recently which gary faced,

    db2 9.5 windows ,
    user was not able to catalog another database which was in linux,
    error don't have proper priviledeges for cataloging db
    User response from the error
    update dbm cfg using catalog_noauth yes
    Using the same user i updated dbm cfg parameter
    then it allowed me to catalog the db (linux)

    I don't understand if its allowing me to update dbm cfg with same user , why its not allowing me to catalog.
    Catalog_NOAUTH -- Sysadmin authority is required to catalog, uncatalog node, db etc
    default is No for server and Yes for client.
    Any one has faced the similar issue, or pls suggest.
    regds
    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •