Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2005
    Posts
    22

    Unanswered: Error while installing ASE-12.5.2 on Fedora 4

    Hi,

    I am trying to install ASE-12.5.2 developer edition on Fedora 4 (2.6.11 kernel),I got following error message while running GUI mode and ./setup -console mode.

    "The wizard cannot continue because of the following error: could not load wizard specified in /wizard.inf (104) "


    I did following pre-installations tasks:
    1) Created sybase user and I am trying to install as sybase ( not root)
    2) Created home directory /opt/sybase-12.5.2 (owner is sybase)
    3) Allocated shared memory by running the following command:
    /sbin/sysctl -w kernel.shmmax=1073741824 and included the same command in rc.local file
    4) Down loaded ase1252_de_linux.tgz, gunzip and untarred
    5) Down loaded j2sdk-1_4_2_10-linux-i586.bin and installed java

    It seems I did all necessary things to install ASE-12_5.2 on Fedora 4, but still I am not able to to that.

    Any help will be appreciated.

    Thanks in advance.
    BSR

  2. #2
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    It is possible that you are being blocked by the SElinux setting. Try to disable SElinux (in /etc/selinux/config, requires a reboot) and see if that helps.

    Michael

  3. #3
    Join Date
    Dec 2005
    Posts
    22
    Michael,

    Thanks a lot for your response,as you suggested I disabled SElinux (in /etc/selinux/config ) and rebooted ,it worked, now I am able to launch the installer, but I got into another problem,after 3 steps while configuring the different servers it is hanging,I saw the following error message in log.txt.


    (Dec 28, 2005 5:34:44 AM), Setup.product.install, com.ibm.wizard.platform.linux.LinuxProductServiceI mpl, msg1, installing Configurator Environment Files (suite_sysam_bean4)
    (Dec 28, 2005 5:39:30 AM), Setup.product.install, com.installshield.wizard.swing.SwingWizardUI, err, java.lang.NullPointerException
    STACK_TRACE: 14
    java.lang.NullPointerException
    at java.net.InetAddress.cacheAddress(InetAddress.java :667)
    at java.net.InetAddress.cacheAddress(InetAddress.java :652)
    at java.net.InetAddress.getAddressFromNameService(Ine tAddress.java:1034)
    at java.net.InetAddress.getLocalHost(InetAddress.java :1142)
    at com.sybase.ismp.ase.wizardbean.ConfigPanel.getHost Name(ConfigPanel.java:532)
    at com.sybase.ismp.ase.wizardbean.ConfigPanel.initPro perties(ConfigPanel.java:154)
    at com.sybase.ismp.ase.wizardbean.ConfigASEPanel.init Properties(ConfigASEPanel.java:24)
    at com.sybase.ismp.ase.wizardbean.ConfigPanel.queryEn ter(ConfigPanel.java:35)
    at com.sybase.ismp.ase.wizardbean.ConfigASEPanel.quer yEnter(ConfigASEPanel.java:31)
    at com.installshield.wizard.awt.AWTWizardUI.currentBe anChanged(AWTWizardUI.java:1646)
    at com.installshield.wizard.StandardWizardListener.cu rrentBeanChanged(StandardWizardListener.java:100)
    at com.installshield.wizard.Wizard$RunThread.run(Wiza rd.java:1564)


    Am I missing some thing?

    Thanks in advance
    BSR.

  4. #4
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    I'm not sure, but it is possible that the JDK that you installed is interfering. I usually do the install without modifying the Java install on the machine, and it has worked fine for me for all my recent (last year or more) installs (FC 2, 3 and 4, RH EL 3 and 4, for ASE 12.5.2 and 15.0).

    Michael

  5. #5
    Join Date
    Dec 2005
    Posts
    22
    Michael,

    I uninstalled JDK which I installed,still I was not able to,but I found the problem,there was no entry in /etc/hosts for my machine,that was the reason installation wizard was hanging while bulilding the servers,I made that change and managed to install every thing.

    Thanks a lot for your help.
    BSR.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •