Results 1 to 4 of 4

Thread: Recompile????

  1. #1
    Join Date
    Feb 2005

    Exclamation Unanswered: Recompile????

    I have a A2K database that has worked fine for over a year until today. When I open the db the main form appears but all of the objects (buttons, text, etc) are not visible. If I click on a spot where a button should be, the button click event fires. When I return back to the main for everything is visible. There ae other strange things going on as well. Too many to state. I guess that my question is ther any way to recover from wha tever is corrupt? Luckily this is on a server that is backed up daily so I can revert to yesterday's copy and only lose a day of data. Not too bad because of the holiday.

  2. #2
    Join Date
    Nov 2004
    Hard to say, but corruption is of course one guess. Have a look here

    and see if you can find it there, else it would probably not hurt to try /decompile on a copy of the db, see
    for a detailed step by step instruction

  3. #3
    Join Date
    Apr 2004
    outside the rim
    I concur: try a /Decompile and then Compile it again. Also, insert a Me.Repaint as the last line in the open event.

    There may be stuff going on in the background, and if your PC is low on virtual memory (read: disk space) the first thing to crap out is generally screen updates as Windows struggles to keep it all going. Check your disk space, and also, try it on a different PC.

    Worst case, use a backup copy - but don't "lose" the data. A few simple queries will add the new data to the backup copy since your DB appears to still be working on a basic level.
    have fun!

    Todd S.
    click to email

    Independent Development Consultant
    Biz db & reports - SQL, Access, Crystal, Seradex and more
    Small, custom, unique programs - Office, VBA, .NET

    Favorite message from Windows:
    There was an error displaying the previous error message

    Sadly, there was no error number to look up ...

  4. #4
    Join Date
    Feb 2005
    Thanks for the replies. I had to get things up quick so no time to troubleshoot. I could still get to the tables of the corrupted db so I exported the tables that change frequently to a temp db and restored the db frome the last backup. Then I exported the tables from the temp db to the restored db. Every thing seems to be back on line.

    I'll have to keep an eye on things because we recently upgraded some PCs to A2003 and left the rest at A2K.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts