Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2005
    Posts
    27

    Angry Unanswered: Aligning text between main and sub reports

    Hey,

    Wondering if anyone could tell me how to get text in subreports to perfectly line up with text in main reports. I have, say, a line of text in the main report that's one tab in. Then a line of text in a subreport under it that's one tab in--but it's off by about 3/4ths of a character (not even a full character! Otherwise I'd pad with spaces). How can I fix this? I have the text boxes set to x 0.0 y 0.0 and 8 inches long, for both the text boxes and the subreports. So you'd think they'd line up perfectly.

    Anyone have a clue?

    Thanks!

  2. #2
    Join Date
    Jan 2006
    Posts
    9

    Re: Aligning text between main and sub reports

    I'm assuming the subreport is just a field (or a few) within a main report. If so...

    1. Make sure you have the grid switched on in design mode and that snap to grid is also on.

    2. Always clear any spacing from the edges of your subreport, that way when you are placing the subreport in the main report, you'll know that your first field will start immediately.

    3. A good trick is to temporarily change the background colour of the object in the subreport (silver is good). That way, when you look at it in the main report you can see exactly the size and position of the object, and line stuff up accordingly.

    Hope this helps!

  3. #3
    Join Date
    Jun 2005
    Posts
    27

    Talking

    Hey thank you. I found out going to the page setup for the subreport and removing the margins helped as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •