Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2005
    Posts
    2

    Unanswered: 2601: SQL1039C error

    Hello,

    I recently had my Dell Inspiron 5000 crash on me. The cause was the Video Card as well as the Processor. I had a DB2 database in there which I had not backed up. The version of DB2 was 7 with fixpack 2. The operating System I was using is Windows 2000 Pro.

    I had attached the hard drive to a machine that was using a newer version of DB2. But it said that I have to upgrade my database. I don’t want to upgrade my database because my customers are using the old database and I want to keep this version in order to support them.

    I replaced the Video card and Processor and was able to start the system. I went into the control center and tried to access the databases I had there. But it gave me the following error:

    2601: SQL1039C An I/O error occurred while accessing the database directory. SQLSTATE = 58031

    My question is, does this mean that my database files are corrupt or does it mean that I have to reinstall DB2 or something else?

    If someone has any ideas, I am very open to try them. I have a copy of DB2 version 7 with fixpack 3. So I can install it on another machine to recover this database and I would appreciate some help in recovering this.

    Thanks.

  2. #2
    Join Date
    Nov 2004
    Posts
    374

    error

    the directory is probably corrupted
    a test could be : rename the local directories and system directories
    then catalog each database again with
    catalog db on c:... whatever was used
    list db directory on c:... could list also the db..
    this for local databases for remote just catalog node/catalog db ...
    Best Regards, Guy Przytula
    DB2/ORA/SQL Services
    DB2 DBA & Advanced DBA Certified
    DB2 Dprop Certified
    http://users.skynet.be/przytula/dbss.html

  3. #3
    Join Date
    Apr 2005
    Posts
    2
    Thanks for the suggestion.

    What are the local and system directories? Are you talking about c:\DB2\NODE0000\SQL00001, c:\DB2\NODE0000\SQL00002, c:\DB2\NODE0000\SQL00003 etc. and c:\DB2\NODE0000\SQLDBDIR.

    By the way I tried Catalog DB without rename the directories and got the same message:

    SQL1039C An I/O error occurred while accessing the database directory. SQLSTATE = 58031.

    Please help me.

    Thanks

  4. #4
    Join Date
    Mar 2004
    Location
    Toronto, ON, Canada
    Posts
    513
    <Lecture mode>
    If it's important, back it up
    </Lecture mode>

    Ok, check the db2diag.log, it should give you some clue as to what db2 is doing when you see that error. If it's a missing file, it often spits out the entire path.

    Not that this will help you without a backup... I'm afraid your database sounds quite dead.
    --
    Jonathan Petruk
    DB2 Database Consultant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •