Results 1 to 8 of 8
  1. #1
    Join Date
    Apr 2002
    Posts
    84

    Question Unanswered: DB2 crash: Agent not allocated, sqlcode -6043

    Dear All,

    My DB2 running in Windows NT platform crashed occasionally with
    the following error. I need to reboot the machine to make it functioning
    again. Any idea what could be going wrong? THANKS!

    ------------------------------------------------------------
    2005-12-30-15.09.09.140000 InstanceB2 Node:000
    PID:294(db2syscs.exe) TID:381 Appid:none
    base_sys_utilities sqleGetAgent Probe:25

    Agent not allocated, sqlcode = -6043

    2005-12-30-15.23.39.796000 InstanceB2 Node:000
    PID:304(db2syscs.exe) TID:423 Appid:*LOCAL.DB2.051230072338
    base_sys_utilities sqledint Probe:0 DatabaseB12

    Crash Recovery is needed.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Code:
    >db2 ? sql6043
    
    
    SQL6043C No FCM request blocks are available.
    
    Explanation:
    
    No FCM request block is available. FCM is unable to increase the
    number of request blocks automatically because the maximum value
    has been reached.
    
     The statement cannot be processed.
    
    User Response:
    
    Try the request again after other processes have freed up some of
    this resource.
    
     sqlcode :  -6043
    
     sqlstate :  57011

  3. #3
    Join Date
    Apr 2002
    Posts
    84

    Question

    and another error in the event viewer:

    The description for Event ID ( 4 ) in Source ( Stacker Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: [EProgram::checkPwd] getPassword errorcode: -805


    but this problem was resolved by itself later. we didn't do anything.

    please help!

  4. #4
    Join Date
    Apr 2002
    Posts
    84
    thanks. but how to prevent this? need to code the logic explicitly
    in the programs?



    Quote Originally Posted by n_i
    Code:
    >db2 ? sql6043
    
    
    SQL6043C No FCM request blocks are available.
    
    Explanation:
    
    No FCM request block is available. FCM is unable to increase the
    number of request blocks automatically because the maximum value
    has been reached.
    
     The statement cannot be processed.
    
    User Response:
    
    Try the request again after other processes have freed up some of
    this resource.
    
     sqlcode :  -6043
    
     sqlstate :  57011

  5. #5
    Join Date
    Mar 2004
    Location
    Toronto, ON, Canada
    Posts
    513
    What do you have set for the dbm configuration parameters FCM_NUM_BUFFERS and MAX_COORDAGENT?
    --
    Jonathan Petruk
    DB2 Database Consultant

  6. #6
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Try increasing FCM_NUM_BUFFERS

  7. #7
    Join Date
    Apr 2002
    Posts
    84

    Question

    FCM_NUM_BUFFERS is 2120, and maxagents 500.
    that was not enough?

    Meanwhile, there is "maximal connection per minutes" in
    the "performance configuration". I changed the value
    from 60 to 120. Does it help?


    Quote Originally Posted by J Petruk
    What do you have set for the dbm configuration parameters FCM_NUM_BUFFERS and MAX_COORDAGENT?

  8. #8
    Join Date
    Mar 2004
    Location
    Toronto, ON, Canada
    Posts
    513
    Quote Originally Posted by qxz
    FCM_NUM_BUFFERS is 2120, and maxagents 500.
    that was not enough?
    I don't know your system but ours is set to 4096, and I can only assume that's the default since I don't recall tinkering with it.
    --
    Jonathan Petruk
    DB2 Database Consultant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •