Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2004

    Red face Unanswered: Oracle 10g on WinXP Pro install problem

    I have WinXP Pro with SP1. ( I plan to update to SP2 only after loading Microsoft
    Office - which is not installed. I prefer to install Oracle 10g Personal first. ) I use
    just one computer at home that is not connected to any other computer.

    During the installation and after typing in my registration code, the install hangs
    at 83% with the error message "Thrown when the IP address of a host cannot
    be determined."

    The 'installactions' file is quite long, but at the end of it there is
    ipaddress = <my address>
    Query Exception:unknownHostException
    Query Exception Class: Class oracle.sysman.oii.oiil.oiilQueryException

    Disabling my Norton AntiVirus doesn't seem to help - and I have WinXP
    firewall disabled. I have no other anti-virus ( or mal-ware ) software installed.

    My C:\Windows\system32\drivers\etc file reads as follows:
    127.0.01 localhost

    During the loading of WinXP I did supply three unique identifiers
    1) Organization 2) Computer Name and 3) Adm Password and then
    I was asked if I wanted to join a Domain which I responded with 'No'. My
    workgroup name is 'Workgroup'.

    I have read some tips on the forum here, but I am sort of lost.

  2. #2
    Join Date
    Jan 2004
    Croatia, Europe
    Provided Answers: 4
    See if this can help you:
    Quote Originally Posted by Metalink
    Problem Description

    You are trying to install an Oracle Product using Oracle Universal Installer.
    During the installation procedure a window pops up saying

    "Thrown when the IP address of a host cannot be determined".

    The installActions.log file has messages similar to the following:

    Calling querynetQueries1. getFullHostName
    Query Exception: UnknownHostException
    QueryException Class: class oracle.sysman.oii.oiil.OiilQueryException

    Query Exception: UnknownHostException
    QueryException Class: class oracle.sysman.oii.oiil.OiilQueryException

    Solution Description

    You should first check the hosts file to see if the correct hostname and the IP
    address are shown.

    For example:

    >cat hosts

    # Internet host table
    # localhost rtcsol loghost rtcsolf
    ==========> after the IP address, one or more aliases for the hostname

    You can also check if the "hostname" command returns the correct result.

    For example:


    If everything looks good so far, then next check if command "nslookup"
    returns the correct IP address.

    The correct IP address should show up when you type

    >nslookup <hostname>

    If the nslookup <hostname> command returns error, you will need to talk to
    the Domain Name Server (DNS) administrator to correct this network
    configuration problem.

    If the nslookup returns correct value and if you still get "Thrown when the IP address of a host cannot be determined", keep ignoring the same and continue installation.


    Without the network being configured correctly, the Oracle Universal
    Installer (OUI) will fail during its checkup on the hostname and host IP

  3. #3
    Join Date
    Nov 2004
    Thanks for the speedy reply.

    My host file which is located at C:\Windows\system32\drivers\etc
    reads as follows: localhost

    But from a dos prompt, when I type in 'hostname', I don't receive
    127.0.01 localhost
    I get 1/2 of my organization name followed by a hyphen and then 6
    alphanumerics. ( When I installed WinXP it asked my to supply an
    organization name, a computer name and then an Administration password.)
    I guess I was supposed to get localhost

    So my hostname is corrupted I assume. I'll look at the WinXP
    communities to find out how to fix this.

    Thanks again.

  4. #4
    Join Date
    Nov 2004

    Red face still a bit confused

    I solved the problem of the 'hostname' command. It now returns the correct
    result. That is, it now returns the name that I assigned to my computer.
    But this doesn't help me install the Oracle software. I still receive the "Thrown
    when the IP ...." error message.

    When I type the Dos command 'nslookup', I receive an address, say From your reply above, I initially thought that all I had to do
    was add a line to my hostfile. That is, I thought that my host file should
    read localhost <hostname>

    instead of simply localhost

    But at the end of the installActions file, an address is mentioned, say
    And when I type in 'ipconfig' at a dos prompt, the following is returned:

    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix: <my connection>
    IP address
    Subnet Mask <some value>
    Default Gateway
    ( I note that the address is not listed here )

    So, my question is, if I have to add a line to my host file - do I use
    the address ( as obtained using nslookup ) - or do I use the address?

  5. #5
    Join Date
    Mar 2004
    I think you are on a DHCP network and do not have a static IP so...
    See "Installation Guide" manual,there is a whole part on this problem.
    -Good luck!

  6. #6
    Join Date
    Nov 2004

    installed loopback adapter

    Yes, thank you. It worked out well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts