Results 1 to 9 of 9
  1. #1
    Join Date
    Oct 2004
    Location
    Warren, MA
    Posts
    1

    Unanswered: ADM0500E error on Windows Server 2003

    We recently installed db2 for windows 8.2 (workgroup server edition) to use with a reporting application from Hyperion. In the event logs on this server, I am getting the below error thrown between 5-20 times a day on the server machine. The user account that is associated with the db2 service is an administrator for this server and has full authority in the database so I am having trouble understanding what this error may be telling me. Any suggestions to eliminate this would be greatly appreciated.

    Bob Cook

    Event Type: Error
    Event Source: DB2
    Event Category: None
    Event ID: 4
    Date: 1/9/2006
    Time: 2:36:30 PM
    User: N/A
    Computer: HYPER
    Description:

    2006-01-09-14.36.30.495000 InstanceB2 Node:000
    PID:1924(db2syscs.exe) TID:6772 Appid:*LOCAL.DB2.060109193634
    oper system services sqloisus Probe:30 DatabaseWCTRLDB

    ADM0500E The DB2 Service does not have the necessary authority to complete the
    command. If a user account has been associated with the DB2 Service, ensure
    that the user account has the correct access rights on the local system and
    access to the Domain Security Database for user authentication and group
    enumeration.

  2. #2
    Join Date
    Nov 2004
    Posts
    374

    adm

    this is trying to get to the warehouse control database..
    this user/service might not be enrolled as warehouse administrator.. or warehouse has not been initialized/started..
    Best Regards, Guy Przytula
    DB2/ORA/SQL Services
    DB2 DBA & Advanced DBA Certified
    DB2 Dprop Certified
    http://users.skynet.be/przytula/dbss.html

  3. #3
    Join Date
    Dec 2005
    Posts
    2

    ADM0500E error

    Same error here...
    So what should we do is we don't want to use the warehouse control database service and don't have it installed??

  4. #4
    Join Date
    Nov 2004
    Posts
    374

    dwhc

    list db directory - should list the databases
    if wctrldb is present and not needed, can be dropped
    check for services warehouse manager server - warehouse manager logger
    these can be disabled if not used.
    Best Regards, Guy Przytula
    DB2/ORA/SQL Services
    DB2 DBA & Advanced DBA Certified
    DB2 Dprop Certified
    http://users.skynet.be/przytula/dbss.html

  5. #5
    Join Date
    Jan 2004
    Posts
    12
    This is proably caused due to the fact that DB2DOMAINLIST is not set. You proably also have SERVER set in the DBM configuration for authentication. The last thing is the user is proably in a domain and not local. If you change to authentication to client and add the DB2DOMAINLIST where the user is located, it should not get this error anymore.

  6. #6
    Join Date
    Jan 2004
    Posts
    12
    In my last post, I was not clear about what user I was talking about. It is more than likely that the error message is not being caused by the instance owner, rather the user that is coming in accessing data. DB2 seems to throw up an error message is the application suer isn't local. Adding the DB2DOMAINLIST should make DB2 go to the domain first rather than local first.

  7. #7
    Join Date
    Jul 2006
    Posts
    1
    in regards to ADM0500E error...
    get done "db2set DB2_GRP_LOOKUP=LOCAL"...and db2stop/db2start....you should not see the error after that...

  8. #8
    Join Date
    Sep 2006
    Posts
    97

    It didn't work.

    Can it be any other issues????

    Quote Originally Posted by vbs
    in regards to ADM0500E error...
    get done "db2set DB2_GRP_LOOKUP=LOCAL"...and db2stop/db2start....you should not see the error after that...

  9. #9
    Join Date
    Sep 2006
    Posts
    97

    It worked after 15 Min.

    Thank you sorry for new thred.

    Quote Originally Posted by smith43017
    Can it be any other issues????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •