Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2005
    Posts
    1

    Unanswered: Subreport with Command and parameter; work in Remedy,but with error

    When running the main and sub - report in Crystal Report 9 Pro, all is well, no errors.

    I then added the report into the Report form of Remedy ARS 6.3 patch 13, (using MS SQL 2000 on a Win2003 server), added a button triggering an activ link with Open Window Report to print the current record (main report) and with information from a second form (in the subreport) with the parameter set to the ID in the second form. I am using Remedy ODBC (AR System ODBC Data Source)

    When testing in AR User V6.3 I receive :
    Error in file xxx.rpt . The table could not be found.
    I then click OK, and the report is printed. The subreport Command SQL goes like this:

    SELECT
    DI_Problem_Management."Request_ID",
    DI_Problem_Management."Short_Description"
    FROM
    "DI_Problem_Management" DI_Problem_Management
    WHERE
    DI_Problem_Management."Request_ID" = '{?PMid}'

    I am linking the {?PMid} to a field in the main report.
    Replacing the WHERE clause by linking, can solve this problem, I know.
    However, I have to use parameters in another subreport with an SQL-command like the following:

    SELECT
    DI_Software."Software_navn", DI_Software."SW_number"
    FROM
    "DI_Software" DI_Software
    WHERE
    DI_Software."SW_number" IN ({?IDs_SW})
    ORDER BY DI_Software."Software_navn"

    Format of {?IDs_SW} is typically ’SW00001’,’SW00102’ or ’0’,’0’

    Can anyone help me with the solution or recommend debugging steps.

    I have tried to check the Remedy logs and used SQL Profiler on my development server, but does not find any useful information.
    I have tried both Remedy User and System DSN.

  2. #2
    Join Date
    May 2006
    Posts
    1
    Did you ever find the solution to this? I have a similar problem.
    Once before when I had this issue, I updated my Crystal Reports software with SP5. This time, when I had the issue, I updated with SP6, but this did not correct my problem. Wondering if you had any luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •