Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2006
    Posts
    2

    Unanswered: MySQL Keep crashing

    Hello:

    I am running a phpBB forum on a PVS, MySQL keep crashing every now and then and my host seem don't know what is the problem or keep telling me something wrong on my script.

    I have the log file for MySQL , but really don't understand what does it say , I would appreciate if someone can help me out and tell me if the log have any information that might help.

    Code:
    060101 18:50:48  mysqld ended
    
    060101 18:51:03  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    mysqld got signal 11;
    This could be because you hit a bug. It is also possible that this binary
    or one of the libraries it was linked against is corrupt, improperly built,
    or misconfigured. This error can also be caused by malfunctioning hardware.
    We will try our best to scrape up some info that will hopefully help diagnose
    the problem, but since we have already crashed, something is definitely wrong
    and this may fail
    
    key_buffer_size=8388600
    record_buffer=131072
    sort_buffer=2097144
    max_used_connections=138
    max_connections=4096
    threads_connected=25
    It is possible that mysqld could use up to 
    key_buffer_size + (record_buffer + sort_buffer)*max_connections = 532447 K
    bytes of memory
    Hope that's ok, if not, decrease some variables in the equation
    
    Attempting backtrace. You can use the following information to find out
    where mysqld died. If you see no messages after this, something went
    terribly wrong...
    Bogus stack limit or frame pointer, fp=0xbdfff678, stack_bottom=0xbd5ffa50, thread_stack=65536, aborting backtrace.
    Trying to get some variables.
    Some pointers may be invalid and cause the dump to abort...
    thd->query at (nil)  is invalid pointer
    thd->thread_id=225968
    
    Successfully dumped variables, if you ran with --log, take a look at the
    details of what thread 225968 did to cause the crash.  In some cases of really
    bad corruption, the values shown above may be invalid
    
    The manual page at http://www.mysql.com/doc/C/r/Crashing.html contains
    information that should help you find out what is causing the crash
    
    Number of processes running now: 0
    060102 17:11:13  mysqld restarted
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    060103 19:29:23  /usr/libexec/mysqld: Normal shutdown
    
    060103 19:29:24  /usr/libexec/mysqld: Shutdown Complete
    
    060103 19:29:24  mysqld ended
    
    060103 19:29:53  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    060103 19:31:04  /usr/libexec/mysqld: Normal shutdown
    
    060103 19:31:06  /usr/libexec/mysqld: Shutdown Complete
    
    060103 19:31:06  mysqld ended
    
    060103 19:31:22  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    060104 13:27:15  /usr/libexec/mysqld: Normal shutdown
    
    060104 13:27:17  /usr/libexec/mysqld: Shutdown Complete
    
    060104 13:27:18  mysqld ended
    
    060104 13:27:46  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    060104 18:59:57  /usr/libexec/mysqld: Normal shutdown
    
    060104 18:59:59  /usr/libexec/mysqld: Shutdown Complete
    
    060104 18:59:59  mysqld ended
    
    060104 19:00:33  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    mysqld got signal 11;
    This could be because you hit a bug. It is also possible that this binary
    or one of the libraries it was linked against is corrupt, improperly built,
    or misconfigured. This error can also be caused by malfunctioning hardware.
    We will try our best to scrape up some info that will hopefully help diagnose
    the problem, but since we have already crashed, something is definitely wrong
    and this may fail
    
    key_buffer_size=8388600
    record_buffer=131072
    sort_buffer=2097144
    max_used_connections=230
    max_connections=4096
    threads_connected=38
    It is possible that mysqld could use up to 
    key_buffer_size + (record_buffer + sort_buffer)*max_connections = 532447 K
    bytes of memory
    Hope that's ok, if not, decrease some variables in the equation
    
    Attempting backtrace. You can use the following information to find out
    where mysqld died. If you see no messages after this, something went
    terribly wrong...
    Bogus stack limit or frame pointer, fp=0xbb7fef68, stack_bottom=0xbadffa50, thread_stack=65536, aborting backtrace.
    Trying to get some variables.
    Some pointers may be invalid and cause the dump to abort...
    thd->query at 0x84012b8 = SELECT u.*, s.*
    			FROM phpbb_sessions s, phpbb_users u
    			WHERE s.session_id = '605ab1ec0a40f1d756d76ff9ef8d6a1f'
    				AND u.user_id = s.session_user_id
    thd->thread_id=246800
    
    Successfully dumped variables, if you ran with --log, take a look at the
    details of what thread 246800 did to cause the crash.  In some cases of really
    bad corruption, the values shown above may be invalid
    
    The manual page at http://www.mysql.com/doc/C/r/Crashing.html contains
    information that should help you find out what is causing the crash
    060105 21:04:02  mysqld started
    Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
    If you do not want to use transactional InnoDB tables, add a line
    skip-innodb
    to the [mysqld] section of init parameters in your my.cnf
    or my.ini. If you want to use InnoDB tables, add to the [mysqld]
    section, for example,
    innodb_data_file_path = ibdata1:10M:autoextend
    But to get good performance you should adjust for your hardware
    the InnoDB startup options listed in section 2 at
    http://www.innodb.com/ibman.html
    /usr/libexec/mysqld: ready for connections
    060106 15:06:27  /usr/libexec/mysqld: Normal shutdown
    
    A mysqld process already exists at  Fri Jan 6 15:06:31 EST 2006
    A mysqld process already exists at  Fri Jan 6 15:09:09 EST 2006
    A mysqld process already exists at  Fri Jan 6 15:09:27 EST 2006
    Log file is too big the full log here http://www.matcharabia.com/logs/sql.html

    Thanks

  2. #2
    Join Date
    Jan 2006
    Posts
    2
    Any Help

  3. #3
    Join Date
    Jan 2006
    Posts
    20
    I would try these sources:

    MySQL support page
    phpBB support page

    These folks should be more attuned to your particular errors. Additionally, try to look at the error log - it clearly says where you can find help for part of your problems. You need to build up your project incrementally and test it instead of tackling the entire heap of problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •