Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2004
    Posts
    3

    Exclamation Unanswered: Bad Performance due to Hardware Move

    Hello Everybody,
    First of all I would like to thank everyone for their knowledgeable advice on this post. I have learnt a lot over the years.
    I recently moved a sybase 11.9.2 server running on a DEC-Alpha 4.0 to a different server running DEC-Alpha 5.0. The storage devices were also moved from EMC symmetric to EMC Clariion with fibre access.
    The ASE configuration for both the servers is the same. Due to the fibre access on the new server, the db load and backup speeds are much faster than the older server.
    There is one large application with about 500 users accessing the 3 databases on this server. However, despite the better hardware and increased memory, we are running into a large amount of locking on the new server. Analyzing several locked queries, we find that table scans are being done everywhere, even though appropriate indexes are present on the tables. This never happened onthe old server. I am sure that I am missing something basic in the new server setup. Really hoping that someone can point me in some direction regarding this issue.
    We had done a similar move for another server one month back succesfully. I have compared the server config for that other server, and its the same as this new server.
    Please Help!

  2. #2
    Join Date
    Sep 2005
    Posts
    42

    Thumbs up re

    check the nos of lock & possible try to increase it.
    See the index is proper or not.Run the query with noholdlock.

    Regards
    Bala


    Quote Originally Posted by DMI_dba
    Hello Everybody,
    First of all I would like to thank everyone for their knowledgeable advice on this post. I have learnt a lot over the years.
    I recently moved a sybase 11.9.2 server running on a DEC-Alpha 4.0 to a different server running DEC-Alpha 5.0. The storage devices were also moved from EMC symmetric to EMC Clariion with fibre access.
    The ASE configuration for both the servers is the same. Due to the fibre access on the new server, the db load and backup speeds are much faster than the older server.
    There is one large application with about 500 users accessing the 3 databases on this server. However, despite the better hardware and increased memory, we are running into a large amount of locking on the new server. Analyzing several locked queries, we find that table scans are being done everywhere, even though appropriate indexes are present on the tables. This never happened onthe old server. I am sure that I am missing something basic in the new server setup. Really hoping that someone can point me in some direction regarding this issue.
    We had done a similar move for another server one month back succesfully. I have compared the server config for that other server, and its the same as this new server.
    Please Help!

  3. #3
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    maybe stats are out of date nd needs running UPDATE STATS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •