Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2006
    Posts
    5

    Unanswered: error installing oracle 9i on xp

    hi,
    i am trying to install oracle 9i on an xp machine that already has 10g installed.
    after starting autorun and selecting install the message 'can not find main class' is displayed and autorun closes down.
    installing on a machine without 10g works fine.
    thanks.
    ed.

  2. #2
    Join Date
    May 2004
    Location
    BA [ARG]
    Posts
    137
    It must be the Oracle Universal Installer version you're using, it's possible that you're trying to install 9i with the latest OUI version delivered with 10g.

    Try running the OUI from 9i.

  3. #3
    Join Date
    Sep 2003
    Location
    Virginia, USA
    Posts
    246
    Sounds like a problem with your CLASSPATH variable. There's a known issue with Oracle 9i Internet Developer Suite when installing on XP Pro systems that already have non-Oracle software. The earlier installation of non-Oracle products may have set CLASSPATH to a value that works for that other installation but is incompatible with 9iDS. Copy the current CLASSPATH variable to a safe place, then delete the env variable, reboot, and install 9iDS. It will re-create CLASSPATH with a supported value.
    MarkRem
    Author, Oracle Database 10g: From Nuts to Soup
    http://www.remidata.com/book_nuts2soup.htm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •