Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2006
    Posts
    14

    Question Unanswered: Output Formresults into a report

    Hi. I have a search input form that then displays an output form and subform
    based on a whereclause. The output forms display the correct results quickly.
    However, to make the report, I just copied the form and subform into the
    report design view. So, there isnt an underlying query to the report. Is there a way I can see the results of the formview in a report without creating a report and subreport.

    When I tried to create a subreport and link the report to the subreport it took forever to search. I have 3 huge tables and 2 queries. The tables have 5 joined properties that link each record. The first query combines location and header information. The second query contains geology information. The subform displays units and thicknesses in a table like fashion:

    UNIT THICKNESS
    1 2
    2 7.5
    3 6

    Thank you very much.

  2. #2
    Join Date
    Dec 2002
    Location
    Préverenges, Switzerland
    Posts
    3,740
    "Is there a way I can see the results of the formview in a report without creating a report and subreport"

    you should not want to avoid a query source for your report unless there is something to this question that you didn't mention!

    if the query runs fast enough to make your form happy, a similar query should run just as fast to make a report happy.

    are you sure that your subreports are necessary? reports are far smarter than forms, and the report grouping property could mean no subreports are needed.

    "I just copied the form and subform into the report design view"
    is an alien thing for me - honestly no idea what you did or what the consequences could be. gotta say that i believe that a decent query is the only reasonable basis for a report.

    izy
    currently using SS 2008R2

  3. #3
    Join Date
    Feb 2006
    Posts
    14
    Thank you for your response. When I made the form using the form wizard, i added fields i needed for header information and geology information. Each is based on on a different query. Then , the form wizard recognized that geology information should be put into a subform. So, header information is in the form and geology is in a tabular subform.

    When i use the report wizard, it doesnt recognize that the geology should be put into a subreport. It just kind of indents it into a new group:

    Location and Header info
    (Indentation) Unit Thickness

    So when i finish the report wizard it tells me "The wizard is unable to preview your report, possibly because another user has a source table open in exclusive mode". So i am using the same queries for the report wizard as the form design but it will not work for report. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •