Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2006

    Unanswered: Newbie post, and Informix buffers query

    Hi there

    Just a quick note for any admin who'll be eyeing this : When I registered first time, a message popped up, informing me that :

    Thank you for registering, $username. An email has been dispatched to $email with details on how to activate your account. Click here to return to where you were previously.

    You will receive an email in your inbox. You MUST follow the link in that email before you can post on these forums. Until you do that, you will be told that you do not have permission to post.
    Must'nt $username and $email address be your username and email address?

    Anyways, on to my two questions :

    1. On one Informix installation (runs on Windows Server 2003 Standard) when we run onstat -d, it gives an error saying that Informix is not a member of the Informix-Admin group. I double-checked, and Informix is a member of the Informix-Admin group. I then created another user, added said user to this Informix-Admin group, and when I try to run onstat -d again, I get the same error message, $user is not a member of the Informix-Admin group. Even the administrator account gives the same problem. (We have planned to reinstall Informix on this particular PC anyway, but suggestions are welcome).

    How do we fix this problem?

    Since we can't access the Informix database, can we simply copy the rootdbs file(s) over to temporary storage, reinstall windows and informix, and copy these back again? (Dbexport won't work due to the account problem). There are data in the database, but we have a catch-22 situation here - can't backup when we can't access the database...

    2. How can we determine the maximum size of the locks and buffers in the onconfig file?
    # Shared Memory Parameters
    LOCKS		150000		# Maximum number of locks
    BUFFERS		80000		# Maximum number of shared buffers
    Should the answers to these questions be already posted, I will appreciate it if you can point (or shove) me to these.

    Kind regards


  2. #2
    Join Date
    Aug 2003
    Hi Lib,

    Please test from windows command as user Informix, run onstat -d, if not work, then define environmen variables %INFORMIXDIR%, %INFORMIXSERVER% and %ONCONFIG%, then test again.
    If work, you can run dbexport for save your databases.


  3. #3
    Join Date
    Feb 2006
    We always run it via the special script which sets %Informixdir%, and all those jolly stuff.

    Won't harm to try though... thanks for the feedback. Will post whether it was successful or not.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts