Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2005
    Posts
    8

    Unanswered: Tables with autoincrement Id columns not populated when using DB2move

    Hi,

    I am trying to transfer data from one database to another database in personal edition of DB2 using db2move.

    When I do the import using db2move tables that has auto increment columns are not populated.

    If this is not possible how can I do cross platform data transer.

    Your suggestions required.

    Thanks.

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    You will have to manually import those tables with columns that are "always" generated (instead of generated by default). You can use the IXF files created by the db2move export, but create individual import or load statements that use the MODIFIED BY IDENTITYOVERRIDE parameter to allow the load/import to work properly.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Jun 2005
    Posts
    8
    I tried to load data to os/400 database using the following command.

    db2 => load from 'c:/data/tab77.ixf' OF IXF MODIFIED BY IDENTITYOVERRIDE insert into MCD_DB.EMPLOYEE

    I get the below given error.

    SQL1325N The remote database environment does not support the command or one
    of the command options.

  4. #4
    Join Date
    Mar 2005
    Posts
    108
    Remote load to OS/400, SO/390 and z/OS are not supported. You have to use import with option INSERT only. IBM is still researching on this issue.

  5. #5
    Join Date
    Jun 2005
    Posts
    8
    THANKS FOR THAT.

    But with IMPORT can I transfer identity columns also? All my tables has Identity columns as primary key. I want to transfer my local database to os/400. Is there a way out.


    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •