Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2005
    Posts
    7

    Unanswered: informix 7.23 replication and create procedure

    I have a 7.23 system replicating to another 7.23 system.

    But I don't understand this...

    I issued a "CREATE PROCEDURE" on the primary, it return successful, shows up when I query it. But it never replicated to the secondary?

    Several checkpoint and log files have since been replicated over, but I am not seeing the procedure ?

    Any thoughts? Anyone? Help?

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,

    Please, verify if the objects that refers they exist in the secondary instance.
    A form to verify it is, desactive the replicación and test to create it with dbaccess in the secondary instance.

    Gustavo.

  3. #3
    Join Date
    Sep 2005
    Posts
    7

    simple test procedure

    Yes the procedure is very simple, which I am using as a test.

    create procedure myproc() returning int;
    return 2;
    end procedure;

  4. #4
    Join Date
    Sep 2005
    Posts
    7

    Solved.

    Well it had nothing to do with the procedure.. There were a bunch of corrupted indexes on the target machine, and although no errors seemed to be logged anywhere, some information was not replicating.

    Restored the previous nights backup to the target machine, let the online logs revover and everything replicates correctly.

    F.L.A.K.E.Y stuff in this release.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •