Results 1 to 3 of 3

Thread: SQL0437W - help

  1. #1
    Join Date
    Oct 2003

    Unanswered: SQL0437W - help

    Hello DB2 Gurus,

    I am working on DB2 UDB 8.1 FP 4 on AIX 5.2. When I am trying to rebinding a particular package I am getting the below error. As per that error message recommending to increase statheap size. Currently statheap set to 2048 and I changed to 4096 then I tried to rebind the package and received exactly same warning message.
    Can some one please help me how to fix this problem?
    Also How do I exactract SQL statement from particulat package?

    rebind EMP.P8313517


    SQL0437W Performance of this complex query may be sub-optimal. Reason code:

    "1". SQLSTATE=01602

  2. #2
    Join Date
    Aug 2001
    You'll have to increase stmtheap and not STAT_HEAP_SZ ...

    And, BTW, this is not an error message , it is a warning message ... You application should work, albeit, with sub-optimal performance

    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Mar 2006
    Short Question consurning this warning. I also get it, but i want to ignore it. Now the problem is the compiler looks what the returncode from the precompile was, and if its not zero, it does not compile the resulting sqc file. Now the db2 precompiler does not return zero if a warning occur. That is, in my opinion, completly wrong.

    Therefore, i would like to completly IGNORE such warnings, they shouldn't even be printed out. Is there any possibility (eg. a flag) which can help me?

    Thanks ^^

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts