Results 1 to 2 of 2

Thread: running Flash

  1. #1
    Join Date
    Jun 2005
    Posts
    8

    Unanswered: running Flash

    Hi,

    I am trying to run a flash from PHP. swf file is available in one location and the required xml will be in another location. Because of this i am getting 'Error in locading data' message.

    This is how i access the flash

    <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="<? echo $flashwidth; ?>" height="420" id="AF_FC2Column" align="middle">
    <param name=movie value="flash/AF_FC2_2_StckdColumn2D.swf?
    dataUrl=<? echo $filename; ?>&chartWidth=<? echo $flashwidth; ?
    >&chartHeight=400"">
    <param name=quality value=high>
    <param name=bgcolor value=#FFFFFF>
    <embed src="flash/AF_FC2_2_StckdColumn2D.swf?dataUrl=<? echo
    $filename; ?>&chartWidth=<? echo $flashwidth; ?
    >&chartHeight=400"" quality=high bgcolor=#FFFFFF width="<?
    echo $flashwidth; ?>" height="420" name="AF_FC2Column"
    align="middle" type="application/x-shockwave-flash"
    pluginspage="http://www.macromedia.com/go/getflashplayer">
    </embed>
    </object>


    If i manually put the xml file in the same directory as where the swf exists, it runs fine.

    Can anybody tell me is there any settings to do in php.ini file for flash??
    Or any other work around??

  2. #2
    Join Date
    Apr 2005
    Location
    Baltimore, MD
    Posts
    297
    Could you show us the HTML output from your php script to load the movie?

    Is your problem that the flash movie will not load or that it does load, but cannot read the xml file?

    This sounds more like a server permissions issue...or something wrong in your flash file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •