Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2002
    Posts
    1,245

    Unanswered: Ora-01031: Insufficient Privileges

    Oracle 9.2.0.6 (client and server)
    Windows 2000 SP4
    OEM 9.2.0.1

    I am unable to connect to my 9i database when using OEM. The error message that I get is "ORA-01031: Insufficient privileges". However I am able to log in to the target database using SQL Plus or by Using OEM in standalone mode.

    I can look in the Windows application log (on the server hosting the Oracle db) and see the audit trail of both the failed logins and the working logins. The working login example looks like:
    Code:
    Audit trail: ACTION : 'CONNECT' DATABASE USER: '/' 
    PRIVILEGE : SYSDBA 
    CLIENT USER: [DOMAIN]\[USERNAME] 
    CLIENT TERMINAL: [HOSTNAME] STATUS: 0 .
    The failed examples look like:
    Code:
    Audit trail: ACTION : 'CONNECT' DATABASE USER: '/' 
    PRIVILEGE : NONE 
    CLIENT USER: [DOMAIN]\[HOSTNAME$] 
    CLIENT TERMINAL: [HOSTNAME] STATUS: 1031 .
    The difference is in the CLIENT USER: parameter where the working versions have my domain user account listed while the non-working versions have the hostname of the workstation I am connecting from followed by a '$'.

    I have the NTS entry enabled in the server SQLNET.ora file (and like I said, I can connect using conn / as sysdba from SQL Plus. I have verified that the connect string that OEM computed for itself is the same as the connect string in my (working) TNSNames.ora file.

    Any thoughts, suggestions or tips would be gratefully accepted.

    Regards,

    hmscott
    Last edited by hmscott; 03-20-06 at 14:49.
    Have you hugged your backup today?

  2. #2
    Join Date
    Jun 2003
    Location
    West Palm Beach, FL
    Posts
    2,713

    Cool


    Maybe a WinDoze problem.
    Otherwise check privileges on the account.
    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  3. #3
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    I've had a similar problem before and I never got an answer from Oracle Support that I really agreed with... something to do with trying to logon to a windows database using / as sysdba...

    Try connecting to the database using SYSTEM... according to Oracle, you should be able to "most" everything using the system account anyway...
    JoeB
    save disk space, use smaller fonts

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Since initial details are somewhat vague, I'll take a guess.
    The fix may involve the initSID.ora parameter
    remote_login_passwordfile='EXCLUSIVE'
    Then again, this could be totally off base.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Aug 2004
    Location
    Manchester, UK
    Posts
    143
    I had a similar problem but creating a remote password file solved it. Like so for solaris if that's what you're on:

    1) Log on to the solaris box as an account in the dba group (usually oracle).
    2) cd $ORACLE_HOME/dbs
    3) orapwd file=orapwYOUR_SID_HERE password=your_sys_password
    4)Shutdown your database
    5) Set remote_login_passwordfile=exclusive in your init.ora/spfile
    6) Startup the database

  6. #6
    Join Date
    Dec 2002
    Posts
    1,245
    Quote Originally Posted by Polly013
    I had a similar problem but creating a remote password file solved it. Like so for solaris if that's what you're on:

    1) Log on to the solaris box as an account in the dba group (usually oracle).
    2) cd $ORACLE_HOME/dbs
    3) orapwd file=orapwYOUR_SID_HERE password=your_sys_password
    4)Shutdown your database
    5) Set remote_login_passwordfile=exclusive in your init.ora/spfile
    6) Startup the database
    Ding! That appears to be the issue. I'll have to wait until the next maintenance window to restart the database. Thanks for the assist.

    Regards,

    hmscott
    Have you hugged your backup today?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •