Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2006

    Unanswered: Backup with OEM problem!

    I'm new to Oracle (9i)!

    I'm using a domain computer (called: databasepc) to backup oracle database!
    The oracle was installed on this computer (not the server).
    When backing up the database (logged on database pc), I see this problem:

    VNI-2015 : The Node preferred credentials for the target node are either invalid
    or do not have sufficient privileges to complete the operation.
    On Windows platforms, the Node credentials specified for the Windows target
    should have the "Logon as a batch job" privilege.

    How to solve this!

  2. #2
    Join Date
    Jun 2003
    West Palm Beach, FL


    Not enough privileges -- try overkill, assign DBA to that account.
    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  3. #3
    Join Date
    Dec 2003
    Oklahoma, USA
    In your OEM console, find out how you are connecting to the target machine. To do this, go to Configuration, then select Preferences, and select the "Preferred Credentials" tab. Scroll down until you see the line that has your Target Name = <host name with database> and Target Type = "Node". Click on that line and in the bottom of the screen you will see the "Username" text box filled in... make note of this.

    Next, go to your host machine, and grant the "Logon as a batch job" privilege to the username noted above. Various Windows OS's have different places to do this, how to do this will vary. In XP and 2K, you can go to "Control Panel", select "Administrative Tools" and then "Local Security Policy". From there, select "Local Policies", then "User Rights Assignment"... find on the right hand side, "Log on as a batch" and double click. Another dialog will open; click "Add...", etc, etc...

    Hope this helps.
    save disk space, use smaller fonts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts