Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2002
    Posts
    1,245

    Unanswered: nms-1029: rman does not exist

    Windows 2000 SP4
    Oracle 9.2.0.6
    OEM

    I get this error message when I schedule an RMAN script. The error message comes with either of the two following syntaxes:

    run {
    delete obsolete;
    }

    or

    delete obsolete;


    The funny (not so funny really) is that this script is the second step of the backup job. The backup job uses RMAN to back up the database (full online backup) and I can see the spool from the RMAN commands and I can see that it is successful.

    Also, I have a similar set at home (9i on Windows 2003) and the same process works just fine.

    So what gives?

    Googling this error yielded some web page in Russian. Not much help there.

    Regards,

    hmscott
    Have you hugged your backup today?

  2. #2
    Join Date
    Apr 2005
    Posts
    1
    MetaLink has the workaround, you're gonna love this...

    RMAN job in OEM Fails with NMS-1029 after 9.2.0.6.0 Patchset Is Applied
    Doc ID: Note:292429.1 Type: PROBLEM
    Last Revision Date: 30-NOV-2004 Status: MODERATED

    The information in this document applies to:
    Oracle Enterprise Manager - Version: 9.2.0.6
    This problem can occur on any platform.
    Errors
    NMS-1029
    Symptoms
    RMAN job fails after applying 9.2.0.6.0 patchset with error: nms-1029: rman does not exist
    Changes
    Issue occurs after patchset 9.2.0.6.0 is applied.
    Cause
    BUG 4019528 Rman Job Fails With Nms-1029 After 9.2.0.6.0 Patchset
    Fix
    Watch for official fix on MetaLink.

    Workaround: http://www.dbforums.com/db_images_v3...milies/eek.gif

    Rename:
    $ORACLE_HOME/bin/RMAN.exe
    to
    $ORACLE_HOME/bin/rman.exe
    References
    Bug 4019528 - Rman Job Fails With Nms-1029 After 9.2.0.6.0 Patchset

  3. #3
    Join Date
    Dec 2002
    Posts
    1,245
    Rename:
    $ORACLE_HOME/bin/RMAN.exe
    to
    $ORACLE_HOME/bin/rman.exe
    References
    Bug 4019528 - Rman Job Fails With Nms-1029 After 9.2.0.6.0 Patchset
    Yep. That worked for me.

    Thanks for following up on that one. I've been beating back other alligators at the moment.

    Regards,

    hmscott
    Have you hugged your backup today?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •