Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2004

    Question Unanswered: Data Protector , Sap Configuration Oracle Database

    Hello , we are triyng to configure the Hp Data Protector for backing an instance of SAP, working with Oracle 92 database. In the Hp DataProtector SAP bakcup configuration window, we have to complete the user name , password and service name.
    We are triyng to use SYS user, but then an error message appears :

    ORA-28009: connection to sys should be as sysdba or sysoper
    SP2-0640: Not connected.

    If we add the text "as sysdba" after the password of SYS suser then the error don`t appears. However when the backup starts the BRTOOLS returns the followed errors:

    BR051I BRBACKUP 6.20 (25)
    BR154E Unexpected option value 'as' found at position 8
    BR154E Unexpected option value 'sysdba' found at position 9

    So, we can not use the SYS user.Somebody knows how we have to fill these fields?

  2. #2
    Join Date
    Jan 2004
    Croatia, Europe
    Provided Answers: 5
    I never used HP Data Protector, but this is how one gets connected to SQL*Plus as a privileged user; maybe it'll give you a helpful hint.

    To connect as SYS, enclose the whole connect string into the double quotes:

    OS> SQLPLUS "sys/its_password@database as sysdba"

    Another privileged user is SYSTEM; it doesn't require you to log on as a SYSDBA, so it would go like this:

    OS> SQLPLUS system/its_password@database

    Perhaps you're lucky and will be able to complete your task following this suggestions

  3. #3
    Join Date
    Aug 2004
    Thanks Littlefood for your suggest ,

    yes, when connect with sql*plus I use this methode and works correctly with both users ( SYS and SYSTEM ).

    But when we try to use this methode with DataProtector SAP Configuration, only the SYSTEM user seems to works ok , at last for backups ( maybe because the text "as sysdba" in not necessary ), but I'm not sure if this user has the enougth privileges to complete also the futures restores/recovers. So, we want to use SYS user.

  4. #4
    Join Date
    Feb 2008
    Do the following
    Login as oracle DBA and change the parameter
    SQL> alter system set o7_dictionary_accessibility=true scope=spfile ;
    >> Then restart the oracle for the parameter to take effect.

    This will solve the problem

    Ramveer Singh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts