We have a desktop used to have SQL 2005 Beta and Visual Studio 2005 Beta Installed on it. After Removing all the beta version, we tried to install SQL 2005 but kept getting error message saying incompatible beta version of .net framework, SQL 2005, or Visual Studio needed to be removed before install. We even installed the new Visual Studio 2005 and .Net Framework 2.0 on there but it's still giving the same error message. Could any help us please? Thanks.