Results 1 to 5 of 5

Thread: RAC database

  1. #1
    Join Date
    Nov 2003
    Posts
    68

    Unanswered: RAC database

    Hi
    I have a RAC database on windows 10gr2 on two nodes.
    When i reboot a node the asm instance is not mounted, i have to do the following
    alter diskgroup mount ...

    How can i do it automatically when i reboot.

  2. #2
    Join Date
    Jul 2003
    Posts
    2,296
    the ASM DISK GROUP or the ASM instance?

    what are the parameters for your ASM instance disk groups?

    show parameter asm_diskgroups
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  3. #3
    Join Date
    Aug 2004
    Location
    France
    Posts
    754
    I had the same problem and solved it by editing the "asm_diskgroups" parameter in the pfiles of the asm instances.

    For example, this is the pfile we're using for instance +ASM1 :

    Code:
    ###########################################
    # Cluster Database
    ###########################################
    cluster_database=true
    
    ###########################################
    # Diagnostics and Statistics
    ###########################################
    background_dump_dest=/opt/app/oracle/admin/+ASM/bdump
    core_dump_dest=/opt/app/oracle/admin/+ASM/cdump
    user_dump_dest=/opt/app/oracle/admin/+ASM/udump
    
    ###########################################
    # Miscellaneous
    ###########################################
    instance_type=asm
    
    ###########################################
    # Pools
    ###########################################
    large_pool_size=12M
    
    ###########################################
    # Security and Auditing
    ###########################################
    remote_login_passwordfile=exclusive
    
    asm_diskstring='ORCL:*'
    asm_diskgroups='DG_DATA','DG_REDO','DG_FLASHARC','DG_UNDO'
    +ASM2.instance_number=2
    +ASM1.instance_number=1
    HTH & Regards,

    rbaraer

    Edit PS : IF I remember correctly The_Duck, in my case the asm instance was started but not all the diskgroups were mounted because they weren't in the pfiles. I believe philio is experiencing the same issue. So if I'm correct, "the asm instance is not mounted" should be "the asm instance starts but not all diskgroups are mounted".
    Last edited by RBARAER; 05-03-06 at 03:33.
    ORA-000TK : No bind variable detected... Shared Pool Alert code 5 - Nuclear query ready .

  4. #4
    Join Date
    Jul 2003
    Posts
    2,296
    Quote Originally Posted by RBARAER
    Edit PS : IF I remember correctly The_Duck, in my case the asm instance was started but not all the diskgroups were mounted because they weren't in the pfiles. I believe philio is experiencing the same issue. So if I'm correct, "the asm instance is not mounted" should be "the asm instance starts but not all diskgroups are mounted".
    That is where I was headed.
    yes, I had the same problem.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  5. #5
    Join Date
    Nov 2003
    Posts
    68
    ok thanks i try this tomorrow

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •