Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2006

    Unanswered: Can't access stored procedures

    Hi everyone,

    let me start by saying that I am totally new to Pervasive (I am working on the version 8). I need to take some data out of Pervasive to use it in some Sql Server Stored Procedures.

    I have created some Stored Procedures in Pervasive to facilitate my work and they worked just fine.

    Unfortunately, I had to do some operations in the software that uses Pervasive and my stored procedures are no longer accessible. I can see them through the Pervasive Control Center (as icons), but when I click on them I get the following message:

    [Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface]Unable to open table: X$Proc.

    I looked through the various tables and I find out that I have to insert a record in the table X$File as to make the X$Proc table come back into the database.

    Unfortunately, though, I cannot inser records in the X$File table by using the INSERT INTO sql statement.

    My question to you experts is the following: how can I insert a new record into the X$File table? Or is there another way to make the X$Proc table come back into the database?

    If I call the stored procedures through the CALL sql statement, they return the correct data, so I assume their sql must be stored somewhere. It must still be there.

    Thanks for your help.

  2. #2
    Join Date
    Dec 2001
    Provided Answers: 4
    Sounds like your DDFs were replaced at one point. To make the X$PROC entry come back, you'll need to:
    1. Temporarily rename PROC.DDF to PROC.OLD
    2. Create a stored procedure (doesn't matter what it's called or what it does).
    3. close the PCC (and any applications using the DDFs.
    4. delete the new PROC.DDF (it's created in step 2).
    5. rename PROC.OLD back to PROC.DDF.
    THe Procedures should be available at that point.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Apr 2006

    just tried your solution and it worked!

    Thank you SO MUCH!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts