Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2006
    Posts
    1

    Unanswered: Informix PHP build error

    Hello,


    I am trying to build php-5.0.4 on solaris 8 so that it interacts with Informix Dynamic Server Version 7.31.FD6.
    I am using client sdk 2.81.FC2, 64 bit esql libraries.

    I am configuring php like this:

    ./configure --with-informix=$INFORMIXDIR


    When I build I get this error:


    Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_mm.lo Zend/zend_default_classes.lo Zend/zend_reflection_api.lo Zend/zend_execute.lo sapi/cgi/cgi_main.lo sapi/cgi/getopt.lo main/internal_functions.lo -lifsql -lifasf -lifgen -lifos -lifgls -lnsl -lsocket -laio -ldl -lelf -lphpifx -lifglx -lresolv -lm -lsocket -lgcc -lxml2 -lz -liconv -lm -lsocket -lnsl -lxml2 -lz -liconv -lm -lsocket -lnsl -lxml2 -lz -liconv -lm -lsocket -lnsl -lxml2 -lz -liconv -lm -lsocket -lnsl -o sapi/cgi/php
    /usr/opt/bin/../lib/gcc/sparc-sun-solaris2.8/3.4.4/../../../../sparc-sun-solaris2.8/bin/ld: skipping incompatible /usr/opt/informix2/lib/esql/libifsql.so when searching for -lifsql
    /usr/opt/bin/../lib/gcc/sparc-sun-solaris2.8/3.4.4/../../../../sparc-sun-solaris2.8/bin/ld: skipping incompatible /usr/opt/informix2/lib/esql/libifsql.a when searching for -lifsql
    /usr/opt/bin/../lib/gcc/sparc-sun-solaris2.8/3.4.4/../../../../sparc-sun-solaris2.8/bin/ld: cannot find -lifsql
    collect2: ld returned 1 exit status
    make: *** [sapi/cgi/php] Error 1



    Does anyone know how to resolve this error ?

    Has anyone else had this error ?

  2. #2
    Join Date
    Oct 2005
    Posts
    12
    Hello,

    you must install the Informix CSDK Kit (www.ibm.com).
    After that, you can compile php with informix support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •