Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2006
    Posts
    5

    Question Unanswered: Problem in accessing Informix DB (9.2-IDS2000 server) through ODBC

    Hello friends,

    I have the following configuration.

    Informix Server : Informix 9.2 (IDS 2000) Running on Solaris 8 machine
    Client : Windows 2000 machine installed with Informix ODBC
    driver (2.90.TC4)

    Now I am trying to connect Informix DB Server through the ODBC.In informix DBserver I have enabled Simple password encryption and it is must for smooth running of my application (csm=(SPWDCSM) ). Now when I am trying to connect to Informix server through ODBC it is giving Authentication error.The handsone work around is to disable the csm option.But I would like to keep the encryption option enabled at the same time I should be able to access the Informix DB through ODBC.

    Is it possible like Both Informix server and Client should have same csm encryption facility.If it is correct how can we configure these settings.I need suggestions on how to configure the CSM option in Informix Client on my windows machine.

    I have configure-concsm.cfg the csm option like this in my Informix server on solaris machine

    SPWDCSM("/usr/users/informix92/lib/csm/libixspw.so","","p=1")

    Now what are all the steps I follow to configure the csm option from the Client.I have installed Informix ODBC driver (2.90.TC4) and I do not found libixspw.so in the lib and its sub directories.Please help me on this ..

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Hi,
    Please test follow:

    _ On server
    By default $INFORMIXDIR/etc/concsm.cfg or define variable INFORMIXCONCSMCFG=$INFORMIXDIR/etc/concsm.xxx and
    add this file on $INFORMIXDIR/etc.
    In the file $INFORMIXDIR/etc/comcsm.xxx write:
    dm4("$INFORMIXDIR/lib/csm/iencs09a.sl","cipher[all],mac[levels:high],switch[cipher:6,key:6]","").
    The name dm4 is add in sqlhosts file: DBSER CONNECT HOSTS csm=(dm4).

    _ On Client
    By default %INFORMIXDIR%\etc\concsm.cfg
    In the file %INFORMIXDIR%\etc\comcsm.cfg write:
    dm4("c:%INFORMIXDIR%\lib\client\csm\iencs09a.dll", "cipher[all],mac[levels:hig
    h],switch[cipher:6,key:6]","")

    Gustavo.

  3. #3
    Join Date
    Feb 2006
    Posts
    5
    Hi,
    Thanks for your reply.Actually the problem get resolved after setting the client configuration file( comcsm.cfg ) like the below
    SPWDCSM("C:\Program Files\Informix\Client-SDK\lib\client\csm\ispws07a.dll","","p=0")

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •