Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2005
    Posts
    22

    Unanswered: license Manager (lmgr) issue

    Hi,

    I successfully installed ASE-12.5.2 on Linux and all the servers (data,backup and monitor) are running fine,but while entering the license key information, lmgr gui appeared ok but I saw following error message in the command window where I started lmgr.

    Shutdown failed: Cannot connect to license server (-15,570:111 "Connection refused")


    I thought, I made a mistake while entering license key info,I re-entered it,and it didn't complain any thing in the gui and command window but it didn't display any message whether it was successful,now I am totally confused whether lmgr accepted the key info or not.


    I saw following messsage in /opt/sybase-12.5.2/SYSAM-1_0/log/stderr.out

    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.



    and in /opt/sybase-12.5.2/SYSAM-1_0/log/lmgrd.log

    14:37:16 (lmgrd) The TCP port number in the license, 29722, is already in use.
    14:37:16 (lmgrd) Possible causes:
    14:37:16 (lmgrd) 1) lmgrd is already running for this license.
    14:37:16 (lmgrd) 2) The OS has not "cleared" this port since lmgrd died.
    14:37:16 (lmgrd) 3) Another process is using this port number (unlikely).
    14:37:16 (lmgrd) Solutions:
    14:37:16 (lmgrd) 1) Make sure lmgrd and all vendor daemons for this
    14:37:16 (lmgrd) license are not running.
    14:37:16 (lmgrd) 2) You may have to wait for the OS to clear this port.
    14:37:16 (lmgrd) Retrying for about 5 more minutes
    14:37:34 (lmgrd) Still trying...
    14:37:52 (lmgrd) Still trying...
    14:38:01 (lmgrd) FLEXlm (v8.3b) started on < Machine Name> (linux) (5/11/2006)
    14:38:01 (lmgrd) FLEXlm Copyright 1988-2002, Macrovision Corporation
    14:38:01 (lmgrd) US Patents 5,390,297 and 5,671,412.
    14:38:01 (lmgrd) World Wide Web: http://www.globetrotter.com
    14:38:01 (lmgrd) License file(s): /opt/sybase-12.5.2/SYSAM-1_0/licenses/license.dat
    14:38:01 (lmgrd) lmgrd tcp-port 29722
    14:38:01 (lmgrd) Starting vendor daemons ...
    14:38:01 (SYBASE) FLEXlm version 8.3b
    14:38:01 (SYBASE) Server started on <machine name> for: ASE_SBE
    14:38:01 (lmgrd) Started SYBASE (internet tcp_port 58455 pid 7833)
    20:38:01 (lmgrd) TIMESTAMP 5/11/2006
    2:38:01 (lmgrd) TIMESTAMP 5/12/2006
    8:38:01 (lmgrd) TIMESTAMP 5/12/2006
    14:38:01 (lmgrd) TIMESTAMP 5/12/2006
    20:38:01 (lmgrd) TIMESTAMP 5/12/2006
    2:38:01 (lmgrd) TIMESTAMP 5/13/2006
    8:38:01 (lmgrd) TIMESTAMP 5/13/2006
    14:38:01 (lmgrd) TIMESTAMP 5/13/2006
    20:38:01 (lmgrd) TIMESTAMP 5/13/2006
    2:38:01 (lmgrd) TIMESTAMP 5/14/2006
    8:38:01 (lmgrd) TIMESTAMP 5/14/2006
    14:38:01 (lmgrd) TIMESTAMP 5/14/2006
    20:38:01 (lmgrd) TIMESTAMP 5/14/2006
    2:38:01 (lmgrd) TIMESTAMP 5/15/2006
    8:38:01 (lmgrd) TIMESTAMP 5/15/2006


    Is there a way I can check whether lmgr accepted the license key info and unlocked all the available features?.

    Please respond.

    Thanks in advance
    bsr

  2. #2
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    This happens because a previous instance of lmgr daemon did not exit properly. grep for lmgr and SYBASE and kill any existing processes.

    Start the daemon using ./lmgrd.

    Then do an ./lmutil lmstat - to check status
    and ./lmutil lmreread - To re-read the licsense.dat file

  3. #3
    Join Date
    Dec 2005
    Posts
    22
    Thanks a lot willy_and_the_ci,

    As you suggested I did grep and killed the lmgr and SYBASE processes and ran following command in one window.

    [sybase@hostname bin]$ ./lmgrd
    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    [sybase@hostname bin]$ 8:42:05 (lmgrd) -----------------------------------------------
    8:42:05 (lmgrd) Please Note:
    8:42:05 (lmgrd)
    8:42:05 (lmgrd) This log is intended for debug purposes only.
    8:42:05 (lmgrd) There are many details in licensing policies
    8:42:05 (lmgrd) that are not reported in the information logged
    8:42:05 (lmgrd) here, so if you use this log file for any kind
    8:42:05 (lmgrd) of usage reporting you will generally produce
    8:42:05 (lmgrd) incorrect results.
    8:42:05 (lmgrd)
    8:42:05 (lmgrd) -----------------------------------------------
    8:42:05 (lmgrd)
    8:42:05 (lmgrd)
    8:42:05 (lmgrd) FLEXlm (v8.3b) started on hostname (linux) (5/19/2006)
    8:42:05 (lmgrd) FLEXlm Copyright 1988-2002, Macrovision Corporation
    8:42:05 (lmgrd) US Patents 5,390,297 and 5,671,412.
    8:42:05 (lmgrd) World Wide Web: http://www.globetrotter.com
    8:42:05 (lmgrd) License file(s): /opt/sybase-12.5.2/SYSAM-1_0/licenses/license.dat
    8:42:05 (lmgrd) lmgrd tcp-port 29722
    8:42:05 (lmgrd) Starting vendor daemons ...
    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    8:42:05 (lmgrd) Started SYBASE (internet tcp_port 54515 pid 15448)
    8:42:05 (SYBASE) FLEXlm version 8.3b
    8:42:05 (SYBASE) Server started on <hostname> for: ASE_SBE
    8:44:56 (lmgrd) Done rereading
    8:44:56 (SYBASE) Rereading license file...
    8:44:56 (SYBASE) Server started on <hostname> for: ASE_SBE
    8:44:56 (SYBASE) Updating feature ASE_SBE
    8:44:56 (SYBASE) Rereading options file...
    8:44:56 (SYBASE) ...Finished rereading

    in another window I ran following commands,please have a look at the output.

    ./lmutil lmstat
    lmutil - Copyright (C) 1989-2002 Macrovision Corporation
    Flexible License Manager status on Fri 5/19/2006 08:44

    License server status: 29722@hostname
    License file(s) on hostname: /opt/sybase-12.5.2/SYSAM-1_0/licenses/license.dat:/opt/sybase-12.5.2/SYSAM-1_0/bin/:

    hostname: license server UP (MASTER) v8.3

    Vendor daemon status (on hostname):

    SYBASE: UP v8.3

    [sybase@hostname bin]$ ./lmutil lmreread
    lmutil - Copyright (C) 1989-2002 Macrovision Corporation
    lmreread successful

    It seems every thing looks ok to me but when I ran following command still a process running for lmgr

    [sybase@hostname log]$ ps -ef | grep SYBASE
    sybase 15448 15447 0 08:42 ? 00:00:00 SYBASE -T <hostname> 8.3 3 --lmgrd_start 446dd93d
    sybase 15539 15457 0 08:51 pts/4 00:00:00 grep SYBASE
    [sybase@hostname log]$ ps -ef | grep lmgr
    sybase 15447 1 0 08:42 pts/2 00:00:00 ./lmgrd
    sybase 15448 15447 0 08:42 ? 00:00:00 SYBASE -T <hostname> 8.3 3 --lmgrd_start 446dd93d
    sybase 15543 15457 0 08:52 pts/4 00:00:00 grep lmgr

    Is there any thing wrong still?.

    in stderr.out I saw following two lines from the begining any idea?

    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed


    Thanks for your time.
    bsr.

  4. #4
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    Look at your lmgrd log, it is talking to you.

    8:42:05 (SYBASE) Server started on <hostname> for: ASE_SBE
    8:44:56 (lmgrd) Done rereading
    8:44:56 (SYBASE) Rereading license file...
    8:44:56 (SYBASE) Server started on <hostname> for: ASE_SBE

    The problem is the license.dat file contains the <hostname>. You should replace this placeholder with the physical hostname.

  5. #5
    Join Date
    Dec 2005
    Posts
    22
    I replaced machine name with <hostname> while posting the question on this forum,it displayed the machine name properly every where

    Thanks in advance
    bsr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •