Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2005
    Location
    pune(india)
    Posts
    24

    Unanswered: db2look utility problem

    Hi all,

    I am facing a problem in using db2look utility on AIX server.

    Scenario:
    I am connecting to an OS390 database from AIX server,then i run db2look to extract DDLs for objects in mainframe database.Surprisingly what i see in outfile is i get DDLs of all the tables in mainframe database as normal but the views are extracted in some special format(special characters strings like @@K).The db2 version on both the system is same.So no case of version mismatching.Can you pleasde help me out in knowing why the views are being extracted in this way? Also if this is a known problem ..how can i extract DDLs for my views and aliases.

    I really don't understand why is this hapenning?

    Has anyone faced such a problem before? urgent help is appreciated.


    Cheers,
    Sinwar

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Having the same version of both DB2 z/OS and DB for LUW is not important since there is no real synergy between release levels.

    For DB2 LUW, you should have the latest client (Version 8 FP 12 if possible) regardless of the DB2 version on z/OS. I don't know what version is need on z/OS, but the later the better (obviously not trivial to upgrade).
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Oct 2005
    Location
    pune(india)
    Posts
    24
    Quote Originally Posted by Marcus_A
    Having the same version of both DB2 z/OS and DB for LUW is not important since there is no real synergy between release levels.

    For DB2 LUW, you should have the latest client (Version 8 FP 12 if possible) regardless of the DB2 version on z/OS. I don't know what version is need on z/OS, but the later the better (obviously not trivial to upgrade).

    Marc,

    Version case was just a possibility i thought of.Thanks for your reply.
    But i couldn't find answer to my problem in your reply.
    Can you give a thought to the problem and advise me something concrete.

    Cheers,
    Sinwar

  4. #4
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Please indicate the DB2 version of both systems. Also indicate the fixpack level of the DB2 AIX server.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  5. #5
    Join Date
    Oct 2005
    Location
    pune(india)
    Posts
    24
    Quote Originally Posted by Marcus_A
    Please indicate the DB2 version of both systems. Also indicate the fixpack level of the DB2 AIX server.
    AIX - "DB2 v8.1.1.16" and FixPak "2"
    OS390 - DB2 V8.2

    Sinwar

  6. #6
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Quote Originally Posted by sinwar
    AIX - "DB2 v8.1.1.16" and FixPak "2"
    OS390 - DB2 V8.2

    Sinwar
    That version of DB2 for AIX was released on May 12, 2003, so it is more than 3 years old and was released well before DB2 8.1 for z/OS went GA (March 26, 2004). Note that there is no DB2 V8.2 for z/OS.

    Therefore, I would highly recommend that you upgrade to DB2 for AIX 8.1 to FP12 and try again. If you still have the problem, I would open a PMR with IBM support.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •