Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2006
    Posts
    3

    Unanswered: Connection Problems SQL2000 on Local Machine

    This may be a stupid newbie question, but being that I'm not a DBA I'm going to ask it anyway.

    We discovered a problem with a clients server (Windows 2003 SBS) when we tried to install Veritas Backup Exec. Backup Exec requires an instance of either SQLMSDE or full SQL. This server has full SQL 2000 sp3a installed on it with a working account application. When backup exec trys to create it's instance it fails.

    Investigating further...when I go into Enterprise Manager (logged in as Domain Admin) I get an error when I select the local server.

    I.E.
    "A connection could not be established to (LOCAL).
    Reason: Data source name not found and no default driver specified.
    Please verify SQL Server is running and check your SQL Server registration properties. blah blah blah.

    Okay the server is running. The accounting application (client/server) is still working. I right click on the server and select "New Server Registration" for the field "server" I click the browse button and the "Active Servers" box is empty..

    I went to check the "Data Sources" under drivers, that field is blank. (no drivers installed). I downloaded MS's component checker and it says "MDAC 2.8 on Windows server 2003 sp1" is installed.

    At this point I have exhausted my knowledge of MS-SQL server. My goal is to get BackupExec installed and NOT break the existing accounting application.

    Any help is greatly appreciated.

    Thanks
    rogerb
    Last edited by rogerb4; 06-19-06 at 17:46.

  2. #2
    Join Date
    Aug 2004
    Location
    Pune,India
    Posts
    94
    Hi there,

    i think the running instance on your server was not installed with the "Mixed Mode" authentication.
    That's where the external application trying to connect on windows login account fials.

    Hope this helps.

    Regards.

  3. #3
    Join Date
    Jun 2006
    Posts
    3
    I think I've determined that there is a named instance of SQL running, but that the default instance is NOT running. How do I start the default instance and not mess up the named instance that is running? I tried "sqlservr.exe" at the command prompt but received a number of errors regard the log files being locked by another process?

    Edit: Nope, my last statement is wrong there. There are two instances running. Which would explain the logfile errors. But...I still can't connect to the server with Enterprise Manger.

    Edit 2: The authentication mode on the named instance was set to 2 (mixed), the default 1(windows), I set the default to 2 and restarted the service. I still can't connect with Enterprise Manager.
    Last edited by rogerb4; 06-20-06 at 12:57.

  4. #4
    Join Date
    Jun 2006
    Posts
    3
    Okay I fixed my own problem. Here's what I found. In the registry under HKLM\Software\ODBC there is an entry "odbcinst.ini". There are suppose to be a list of installed drivers here. In my case this key was empty. So I created the SQL Server key and the Text value"Driver" which equals, "c:\winnt\system32\sqlsrv32.dll.

    And....I can get into the default instance now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •