Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2006
    Posts
    2

    Question Unanswered: OPENROWSET using Visual FoxPro Provider error 'Could not fetch a row'

    Hi,
    I have 2 separate clients experiencing this problem,
    Both systems are
    1. Win 2000 Server with Small Business Server 2000 (SP4)
    2. SQL Server 2000 (SP2 upgraded to SP4, SP4)
    3. Exchange
    4. IIS etc

    We use SQL Server to connect to FoxPro 2.6 Tables.

    We are using OPENROWSET as follows:

    Select * from openrowset('VFPOLEDB.1','C:\Client Data';;,'Select * from cm')

    We are now getting this error:
    Server: Msg 7330, Level 16, State 2, Line 1 Could not fetch a row from OLE DB provider 'vfpoleDB.1'. OLE DB error trace [OLE/DB Provider 'vfpoleDB.1' IRowset::GetNextRows returned 0x80040155].

    The statement worked up until around 20 days ago, which made us think that it may be windows updates/sps/hotfixes, but i have installed the above on a test machine and installed all windows updates and the test machine works AOK.

    Has anybody seen this error?

    Thanks in advance
    Q

  2. #2
    Join Date
    Jan 2004
    Location
    In a large office with bad lighting
    Posts
    1,040
    1. What has changed since the last time it worked?
    2. Did you also copy the file you are trying to read from to your test machine as well? If this is a file that is updated daily, someone may have garbaged it up for you. Maybe someone even added a column or invalid data?

    -- This is all just a Figment of my Imagination --

  3. #3
    Join Date
    Jun 2006
    Posts
    2
    1.Well, as per the usual user response "nothing has changed"... Nothing has been installed or uninstalled. We've looked at the machine, even used sysinternals filemon to see if its getting to the path where the tables are, and no visible problems.

    Strange thing is, if the foxpro table is empty then using OPENROWSET as described within Query Analyzer will return with no error, it seems as if its only once the table has data in it. And its not limited to 1 table, its all of them.

    2. Its happening with all the tables, which have not had their schemas modified. If I copy a file from a test machine to the server it doesnt work either, whereas moving the file from the server to a test machine and calling
    OPENROWSET works successfully.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •