Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2001
    Posts
    7

    Unanswered: umask for utl_file

    Hi,
    when i generate a file using utl_file package, the permisions are 644. I require the permissions to be changed to 664. how can i do this. I guess this package uses umask set some where. How do i change that default umask value.


    Bye.

  2. #2
    Join Date
    May 2006
    Posts
    132
    Correct, by default files created with UTL_FILE are created by the owner associated with the Oracle process. Therefore, the owner's umask will be applied to the files. You would have to changed the umask associated with the owner of the oracle process. You can change the default umask by setting umask 113 (in your case) in the .profile or .login file.

  3. #3
    Join Date
    Sep 2001
    Posts
    7

    umask for utl_file

    Hi Ebrian,
    Thanks for your answer. But i have a doubt. When the utl_file package is executed from the procedure, i guess it does not execute the .profile/.login of the oracle process. So how does the setting in .profile take effect.


    Bye.

  4. #4
    Join Date
    May 2006
    Posts
    132
    That's correct, however if you were to log on the database server as the owner of the oracle process and issue simply umask, this will tell you what UTL_FILE will use.

  5. #5
    Join Date
    Sep 2001
    Posts
    7

    umask for utl_file

    Thanks very much. I will try it.

    Bye.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •