Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2006

    Unanswered: Problem using Access - need help!

    Help! Basic Access 2000 user here!

    Have been using Access 2000 from time to time over the years and recently installed Access 2000 (official original purchased CD, not a bootleg!) on a new computer running XP SP2.

    When opening an existing database or opening a new blank database, I get the error "too many active users" and this keeps me from using Access.

    I've searched my computer for any ldb files and found one which was System in the Office folder. I've deleted this file and rebooted but it reappears each time I launch Access. I've searched items in the forums that relate to "too many active users" but they do not apply to new database files.

    The computer is not connected to a network or server and not part of any workgroup. My copy of Access 2000 is a retail version registered to only me and not a workgroup. The few databases I have on the computer were never associated with a workgroup (used for personal use only) and I have removed them but I get the same error. After launching Access and trying to create a new database, I get the same error message. Is there any setting in Access that can be changed before opening a new or existing database? Is there any setting in XP-SP2 that could be causing this?

    Can anyone help me solve this? (I've already uninstalled and reinstalled several times.)

    Thanks in advance!

  2. #2
    Join Date
    Sep 2003
    Search this forum for "too many active users" ... I thought I saw a solution (or at least a discussion) on this just recently ...
    Back to Access ... ADO is not the way to go for speed ...

  3. #3
    Join Date
    Oct 2004
    Oxfordshire, UK
    If I remember correctly this problem can be created by not closing down references to workspace and database objects opened in code.
    If you've got:
    Set wspCurrent = DBEngine.Workspaces(0) or DBengine.CreateWorkspace(...
    Set dbCurrent = wspCurrent.OpenDatabase(...

    In DAO make sure it's followed by this sort of thing somewhere in the code:
    [wspCurrent.Close if CreateWorkspace used]

    At the very least it should have
    set dbCurrent=nothing
    set wspCurrent=nothing

    A similar argument applies to ADO connection objects.

    Oh and delete, any ldb files relating to this database that might be hanging around 'cos they'll contain invalid info.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts