Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2006
    Posts
    56

    Exclamation Unanswered: Oracle + Asp: End Of File through ASP, but get rows in TOAD

    Hi y'all

    Some help here please

    'Define SQL
    SQL = "select "
    'Table Orders
    SQL = SQL & "schema1.orders.order_sid, "
    SQL = SQL & "schema1.orders.order_date "
    'From Table Orders
    SQL = SQL & "from "
    SQL = SQL & "schema1.orders "
    'Where --> Only not Ready-to-Go Orders ...
    SQL = SQL & "where "
    SQL = SQL & "readytogo = 0 "
    'And --> From Session User
    SQL = SQL & "and "
    SQL = SQL & "user_sid = '" & Session("user_sid") & "' "
    'And --> From the Selected Company
    SQL = SQL & "and "
    SQL = SQL & "company_sid = '" & Session("company_sid") & "' "

    Now, the Columns here are
    order_sid - Number(10)
    order_date - Date
    readytogo - Number(1) with Constraint for 0 or 1 only (False ou True)
    user_sid - Varchar2(12) (sorry, I had it like Char(12) before)
    company_sid - Char(14)

    Then, the SQL String results in:
    ...
    where
    readytogo = 0
    and
    user_sid = '773433'
    and
    company_sid = '153'

    Here's the thing: When I run this code in ASP, I get EOF and BOF true. That means there are no matches. But yes, there are. When I run it in TOAD, I get 1 row.

    To complete the info, the user in toad is toplevel, and the site user only has grants for SELECT, INSERT, UPDATE and DELETE. Although I do not think that's the problem, since I also tried it on the site with the toplevel user...

    Furthermore, the Provider is MSDAORA, CursorLocation = 3, and Oracle version is some 9i, not too sure.

    Did this ever happen to anybody? Does anyone have any clues as to WHY this is happening?

    Please, any help would be extremely appreciated.
    (and if you clueless like me, thanx for reading anyways)
    Last edited by igordonin; 07-21-06 at 17:26.

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    If you inserted the record through TOAD and your SELECT statement returns it back (but you can't see it in ASP), did you perhaps forget to COMMIT inserted data in TOAD? If you don't do that, noone but your current session will be able to see this data.

  3. #3
    Join Date
    Jul 2006
    Posts
    56

    Ouch!

    Ouch!!!! Did I forget to commit?!?!?!?! Guess now I'll never know, because I dropped the table and created it again. It's working fine now... But since you mentioned, I could've forgotten to commit... Never thought of that!

    Thank you anyway

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •