Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2006
    Posts
    3

    Unhappy Unanswered: MS Access Db will not open

    I have a ms access db that will not open. If I use file/open from the menu and select the db, I get the hour-glass for a few seconds and then back to the regular cursor. The file size for the db is 8282kb. I've tried compact/repair on the same db. It doesn't help. Double clicking the file has the same result.

    Any suggestions? It's going to take awhile to get the file from backup so if there is anything else that can be done in the meantime, it would be great.

    thanks

  2. #2
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926

    Access File

    Can you create a new MSAccess db and import from this one into the new one?
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

  3. #3
    Join Date
    Jul 2006
    Posts
    3

    import/linking

    I tried importing to a new db and it did not work. I've also tried linking tables in the new db to the one that will not open - no luck.

  4. #4
    Join Date
    Sep 2003
    Location
    MI
    Posts
    3,713
    No errors on trying to open? Do you have anything running on startup that could blow?
    Back to Access ... ADO is not the way to go for speed ...

  5. #5
    Join Date
    Jul 2006
    Posts
    3
    No errors. Just the hourglass, then the cursor.

    Of course the person that created this db & maintains it is out.
    The user was able to open the db this am. She was trying to save her work when it locked up on her.

  6. #6
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926

    Bad db

    I guess at this point I would need some more info (is this an mde or mdb). If it's an mde file your working with, the mdb has got to be somewhere. Assuming you're working with the mdb, here's some of the steps I'd take:

    1. Open with the shift key, debug, compile, etc...Make a new mde...etc...
    2. Copying and pasting the mdb file to another mdb name and then trying that.
    3. Import into a fresh mdb.
    4. Open the mdb using one of the parameters (can't remember them).
    5. Does rebooting help?
    6. Suggestions from others on this forum....

    Questions I'd ask myself:
    1. Does it happen on any other machine.
    2. Does it debug/compile correctly.
    3. Is there an *.ldb file still hanging out there in that folder that if I delete that *.ldb file, it might work (I'd be interested in knowing if there is still an *.ldb file in the folder telling Access to think the file is opened by a user).

    I'd personally want to know what happened and not just restore the backup and let it go at that but it sounds like you don't have an MSAccess geek on hand. Are the data tables in this one MSAccess mdb or are they split/linked tables?
    Last edited by pkstormy; 07-24-06 at 16:19.
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •