Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2006
    Posts
    2

    Red face Unanswered: Blank pages, yet groups on left pane and plenty of data.

    I have the weirdest situation in Crystal 8.

    3646621 million rows of data are getting chugged through. The report runs the amount of time it should run, it cycles through the amount of data it should, but, when itís done, it does not show any data on the page. You also can't cycle through the pages either as if the report didn't have any pages except the first. The groupings are on the left, but when you try to expand them or drill down into them you can't. When you click on a group it says "generating group tree" but then it just doesn't do anything and no drill down occurs.

    The report has PLENTY of data, but itís as if it just decides to give up processing. My gut would have normally of told me to blame it on memory, or the amount of data, but get this....

    If I run this report with ANY month long date range BEFORE 4/1/2006, the report RUNS JUST GREAT!!! If I run 2/1/2006 to 2/28/2006, its fine, if I run 3/1/2006 to 3/31/2006, it runs fine. If you run 4/1/2006-4/30/2006, it craps out and displays a blank page. Get this; it chugs through the exact same amount of data when it does those months!!! 5/1/2006 Ė 5/31/2006, 6/1/2006 Ė 6/30/2006 also do NOT work.

    Here are my guesses:

    1. Something in the data changed after 4/1 that the users aren't able to tell me about. Iíve asked and asked and asked and they donít know of any changes.
    2. Crystal Reports is corrupted and needs to be reinstalled.
    3. Run this in a newer version to see what happens. I'm waiting for my company to get me some disks.
    4. Something on machine that Crystal is running on is messed up. Re-build the machine?

    I canít do guesses 2, 3 nor 4 just yet, while number 1 keeps getting me know where since the users arenít telling me anything is different, and I canít find anything in the data to indicate the data is different.

    Does anyone have any other ideas? Any suggestions?

    Help!!!

    Keith

  2. #2
    Join Date
    Aug 2006
    Posts
    2
    I am also running into similar kind of problems. I have a report with 3 subreports. It runs fine b/w 4/1/2006-8/17/2006. But nothing is displayed when it is ran b/w 1/1/2006-8/17/2006. I looked into storeprocs, and it is getting data. When I pointed the report to PILOT instead of Development database, it craps b/w 1/1/2005-8/17/2005 but runs fine 8/1/2005-8/17/2006. I think it is some do with the data. I also tried to reconstruct the report, but still the same problem. So I am waiting for the report to be promoted to other environments like Testing and eventually to Production. Hope everything works fine in PROD.

  3. #3
    Join Date
    Aug 2006
    Posts
    12
    What is the record count in the bottom right corner after the report cycles through (the bottom left displays "For Help, press F1")?
    Is it 0? When its "cycling" through, does the record count show 0 of 3646621 million records? If it does show zero, something is out of whack with your selection critera or your links (joins).

    Otherwise, I would make the same suggestions as the guy above.

    Check your data source first to see if its returning records for the date ranges after 4/1/2006. If the data source is a view, query or stored procedure, there could be a problem with it. If no data is returned, check the individual tables used in the SQL code. You may need help from your database administrator if you don't have access to SQL tools or you don't know SQL.

    If the data is returned from above, try writing a simpler Crystal report. Use only a few fields but select the same data ranges.

    Also, try seeing what the data looks like from the front end (the application...Lawson, JDEdwards, Oracle, etc.). Try talking to some of the experienced users. Maybe somebody new was hired and they didnt' run some sort of "update" program because "nobody told them to". Sounds unbelievable but I've worked in places where this was the case.

    If you are not application support, talk to one of those guys to see if they know of something around that time frame. Or, call the application vendor.

    But, start simple. Don't go straight to the application vendor. Nine times out of ten, its something much more simpler, usually on your end. Keep looking at the report to make sure something in the selection criteria, conditional formatting, joins (links) isn't out of whack. If you run around getting everyone else involved, you better make sure your end is error free or you're going to feel like an idiot later on.

    Good Luck!
    Last edited by crystalK; 09-06-06 at 16:36.

  4. #4
    Join Date
    Aug 2004
    Posts
    15
    I have had a similar problem and it turned out to be the way the tables were joined (I love cleaning up after others). It was burried in a subreport too (when the subreport was not needed to make it worse).

    I had to start a brand new report and recreate it one step at a time to find my problem.

    Philip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •