Hi,

I've a 32bit v8 client (AIX and Win). It's able to connect to a 64bit v8.1.5 server AIX (single node). But it's not able to connect to another multi-nodes instance in the same machine.

Got this :

SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "192.168.134.169". Communication function
detecting the error: "recv". Protocol specific error code(s): "*", "*", "0".
SQLSTATE=08001

I did a series of test on 2 instances, testi55 and db2inst2, within the server.

testi55=2 logical nodes instance


Test 1 = Loop-back Connection

db2 "catalog tcpip node dlnode1 remote 127.0.0.1 server 60055"

db2 "catalog database db55 as dldb1 at node dlnode1 authentication server"

Connected.

================================================== =============================

Test 21 = IP Connection

db2 "catalog tcpip node dlnode2 remote 192.168.0.2 server 60055"

db2 "catalog database db55 as dldb2 at node dlnode2 authentication server"

SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "192.168.0.2". Communication function
detecting the error: "recv". Protocol specific error code(s): "*", "*", "0".
SQLSTATE=08001


================================================== =============================

Test 3 = DNS Connection

db2 "catalog tcpip node dlnode3 remote test.com server 60055"

db2 "catalog database db55 as dldb3 at node dlnode3 authentication server"

SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "192.168.0.2". Communication function
detecting the error: "recv". Protocol specific error code(s): "*", "*", "0".
SQLSTATE=08001



db2inst1=Single node instance.


Test 1 = Loop-back Connection

db2 "catalog tcpip node dlnode1 remote 127.0.0.1 server 60080"

db2 "catalog database mydb as dldb1 at node dlnode1 authentication server"

Connected.

================================================== =============================

Test 2 = IP Connection

db2 "catalog tcpip node dlnode2 remote 192.168.0.2 server 60080"

db2 "catalog database mydb as dldb2 at node dlnode2 authentication server"

Connected.

================================================== =============================

Test 3 = DNS Connection

db2 "catalog tcpip node dlnode3 remote test.com server 60080"

db2 "catalog database mydb as dldb3 at node dlnode3 authentication server"

Connected.


It seems like I'm missing something. Is it due to DPF licensing ? Can anyone please show me some light ?

TIA !