Anybody experience the following problem and have a solution for it?

Let me explain the problem first .
I have db2 8.2.x installed on an XP box say Machine A and Windows 2003 box say MAchine B. Machine A is the owning instance while the MAchine B is the participating node. The instance directory lies on Machine A. There is a share on the instance directory and db2instprof is set correctly to the sharename.
When I run db2_all "<<+1<db2 list tablespaces" from Machine A it gives me SQL 5005C : system error. Node 1 is Machine B.
If I run the same command from Machine B it works without any problems or if I run db2_all "<<+0<db2 list tablespaces".

Initially thought the problem was that the instance directory pointed to by db2instprof did not have the right permission so I granted Everyone full control over that directory but it did not solve the problem. Then I moved over the instance directory to Machine B and set db2instprof to the new location but that did not solve anything.

If anybody has run across this problem and has a solution , could they please post a reply with the solution.