Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2006

    Unanswered: replication agents all say "server execution failed"

    This is the most frustrating error I've ever encountered.

    I can get no more info from sql server besides "server execution failed". It gives this error when starting the snapshot, distribution, and log reader agents.

    This server has been working in this configuration for over a year. We made no changes except restarted the server. This is a windows 2003 server with sql server 2000 running all the latest patches and windows updates.

  2. #2
    Join Date
    Feb 2004
    In front of the computer
    Provided Answers: 54
    Many of us don't bother to check the usenet posts. The quality varies too much, ranging from the occiasion gem to the overwhelming majority of ads for porn, viagra, etc. I've moved your post to the SQL Server forum, where there's a lot better chance that someone will read it and respond.

    Did the password change for the Windows Login that is used for your SQL Agent change? That's by far the most common reason for this error message based on my experience.

    If the Windows password hasn't changed, then:

    Open SQL Enterprise Manager
    Open the server that is your SQL Distributor
    Open the SQL Agent
    Open Jobs
    Right click on a logreader job
    Click on View Job History...
    Click the Show step details checkbox
    Look for clues!


  3. #3
    Join Date
    Dec 2002
    Also, you can try opening a SQL Profiler session (on the Publisher, Distributor and Subscriber databases unless you have a specific idea of where the error occurs). Look for clues there.


    Have you hugged your backup today?

  4. #4
    Join Date
    Aug 2006

    problem solved

    I ran the snapshot agent from command line as suggested on another forum. It returned an error that atl71.dll was missing. I copied the missing file to the system32 directory and all is now well.


  5. #5
    Join Date
    Dec 2008

    same error

    So I had the same error and followed the process and it worked. So the big question is what caused this? In my instance, I would calk it up to a failed install of Symantec Endpoint Protection. Has anyone else had this experience?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts