Results 1 to 3 of 3
  1. #1
    Join Date
    May 2005

    Post Unanswered: Postgres table corrupt :eek:

    Hey all,

    I’ve run into a massive problem – and don’t have a CLUE how to resolve it …

    I was working on one of my tables in my database with pgAdmin III, using the properties box to add a primary key constraint to 2 columns.

    I accidentally clicked okay and pgAdmin froze so I closed the program using the task manager.

    Now I cannot access the table that I was working on – although I can access all other objects within the database.

    I have tried to delete the table – with no success, make a backup file – which also does not work and am now running out of ideas as to how to resolve this problem.

    I know one messy solution would be to create another table in place of the now corrupt table (?) – but this would run into problems if I needed to create a backup.

    Is there anyway that I can delete this table, or restore all other objects except this one faulty table???

    Any helps/suggestions will be VERY much appreciated!

    Ps – our computers are backed up on a daily basis – if I restore last nights version (I am assuming one would have to replace the data file within postgres 8.1 ???) would this possibly work?

  2. #2
    Join Date
    Nov 2003
    Provided Answers: 8
    Sounds like there is still a lock on the table.
    Maybe restarting Postgres would help.

  3. #3
    Join Date
    May 2005
    Thats exactly what the problem was! As soon as I restarted the service, all worked well!

    Thanks V much shammat!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts