Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2005
    Location
    Bangalore,India
    Posts
    39

    Exclamation Unanswered: Not able to access any of the System functions

    Environment: UDB V8.1 Personal Edition, Fixpack 3, Windows XP

    I have a weird problem while accessing any of the system defined functions. I am getting the below error message.

    SQL0440N No authorized routine named "SUBSTR" of type "FUNCTION" having compatible arguments was found. SQLSTATE=42884

    I checked in the catalog tables that all functions are exist under SYSFUN schema. I thought some of the DLLs(packages) are missing and rebounded all the packages related to system functions.

    db2 bind "%DB2PATH%\bnd\@db2ubind.lst" blocking all grant public
    db2 bind "%DB2PATH%\bnd\@db2cli.lst" blocking all grant public

    Still I am not able to access any of the system functions and getting the same error.

    FYI..I created one more database under the same instance and I am able to access all the functions. I believe this problem is only at database level.

    Please advise what needs to be done in resolving this issue.I appreciate your kind help in this regard.
    Thanks,

  2. #2
    Join Date
    Jan 2003
    Posts
    1,605
    Hi,
    It looks like you have access to this functions, but not using the correct sintax. Can you post select statement to see if you are using correct sintax?
    Grofaty

  3. #3
    Join Date
    Feb 2005
    Location
    Bangalore,India
    Posts
    39
    Grofaty,
    I am using the correct syntax as below..

    db2 "values (substr('sample text',1,6))"

    1
    ------
    sample

    1 record(s) selected.


    Thanks,

  4. #4
    Join Date
    Feb 2005
    Location
    Bangalore,India
    Posts
    39
    Please ignore my previous post,which was showing correctly in other dabase in the same instance.

    Below statement was run against the corrupted DB.

    db2 "values (substr('sample text',1,6))"

    SQL0440N No authorized routine named "SUBSTR" of type "FUNCTION" having compatible arguments was found. SQLSTATE=42884

  5. #5
    Join Date
    Jul 2006
    Location
    Pune , India
    Posts
    433
    there is a bug regarding same. chk details:

    http://www-1.ibm.com/support/docview...&cc=us&lang=en

    --Rahul Singh

  6. #6
    Join Date
    Feb 2005
    Location
    Bangalore,India
    Posts
    39
    Thanks Rahul,

    I believe we can fix this issue by installing fixpak 10.I will try to install and let you know the status.

    Thanks,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •